1

My System: OS: Linux Mint 18 Sarah KDE Plasma 5 laptop: Acer Aspire V112p

this is the output of the command xinput

    xinput
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ ELAN Touchscreen                          id=10   [slave  pointer  (2)]
⎜   ↳ SYN1B7D:01 06CB:2991 Touchpad             id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]                                                                                           
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]                                                                                           
    ↳ Power Button                              id=8    [slave  keyboard (3)]                                                                                           
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]                                                                                           
    ↳ HD WebCam                                 id=11   [slave  keyboard (3)]                                                                                           
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]                                                                                           
    ↳ Acer WMI hotkeys 

basically the cursor would sometimes all of a sudden just move erractially across the screen. I have no idea what's causing this problem.

I've checked using xinput test, and i'm now very positive that the touchpad(id=12) is the one that's causing the problem.

1
  • Does your touchpad have any damage like dents or scratches? Is there any dust or other material wedged under the edges of the touchpad? Does the mouse cursor always move in the same general direction by itself?
    – Criggie
    Dec 7 '16 at 9:40
2

Go to System Settings -> Input Devices -> Touchpad -> Enable/Disable

There are various options there that you can configure to help you resolve the issue. I guess you need to disable the touchpad while typing and/or while an external mouse is connected.

3
  • tried "disable touchpad while typing" , still won't work. I don't have an external mouse
    – applepie
    Dec 7 '16 at 0:27
  • I'm just guessing, can this problem be solved if I install synaptics ? (or libinput )
    – applepie
    Dec 7 '16 at 0:29
  • Hmmm..... In my case I never needed to use anything else like synaptics. You could give it a try though :\
    – jsalatas
    Dec 7 '16 at 0:31
0

https://wiki.archlinux.org/index.php/Touchpad_Synaptics describes many options you can experiment with to make the touchpad less sensitive, and to debug problems. (It's not Arch specific.) Fiddling with synclient has sometimes helped me.

0

Unless there is no paranormal activity at your work place and no hardware issues, this shouldn't happen :)

There are many possible ways you can check/debug this issue.

  • First of all make sure whether it happens only for touch pad or even for mouse events.
  • Reset your touch pad settings to default settings.
  • Analyze what kind of events you are getting when it moves randomly using evtest /dev/input/event* (Since you have touchscreen events might comes thorugh touch also)
  • Reinstall the driver for your touchpad.
  • Last but not the least take it to the repair shop :)
0
0

In my case this worked : I removed the back of the laptop and took out the battery which sits exactly below the touchpad. Then I put a piece of 15x7cm aluminum foil on the battery and covered it with masking tape to avoid any shortcuts.

After that I placed the battery back and closed and tightened the cover and voila: problem solved!

Found the tip somewhere else on the web and gave it a try and it seems to work.

Kees Lemmens

-1

I had the same problem after updating ubuntu 18.04LTS in my case the cursor is moving in a horizontal direction and hardly in vertical what I did is a bit different, I have got a bootable flash drive of ubuntu 20.04 and I tried booting it with that and the cursor was moving fine in live ubuntu then I logged back into my ubuntu 18.04 and voila my cursor is back to normal.

P.S. I originally logged into to live ubuntu because I wanted to check whether my touchpad is broken or not but end up solving the issue, I guess it has something to do with the firmware (I shot in the dark and it hit the bullseye XD)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.