1

I'm trying to install dig through bind-utils on an AWS EC2 RHEL 7.3 instance, but I get a dependency error.

Requires: bind-license = 32:9.9.4-37.el7

but

Installed: 32:bind-license-9.9.4-38.el7_3.noarch

I tried installing the required version like so since is is available, but without success:

[root@ip-171-32-49-95 tmp]# yum install bind-license-9.9.4-37.el7.noarch
Loaded plugins: amazon-id, rhui-lb, search-disabled-repos
Package matching 32:bind-license-9.9.4-37.el7.noarch already installed. Checking for update.
Nothing to do

What gives? How can I get bind-utils to install here?

Here is the full transaction log:

[root@ip-171-32-49-95 tmp]# yum install bind-utils
Loaded plugins: amazon-id, rhui-lb, search-disabled-repos
Resolving Dependencies
--> Running transaction check
---> Package bind-utils.x86_64 32:9.9.4-37.el7 will be installed
--> Processing Dependency: bind-libs = 32:9.9.4-37.el7 for package: 32:bind-utils-9.9.4-37.el7.x86_64
--> Processing Dependency: libbind9.so.90()(64bit) for package: 32:bind-utils-9.9.4-37.el7.x86_64
--> Processing Dependency: libdns.so.100()(64bit) for package: 32:bind-utils-9.9.4-37.el7.x86_64
--> Processing Dependency: libisc.so.95()(64bit) for package: 32:bind-utils-9.9.4-37.el7.x86_64
--> Processing Dependency: libisccc.so.90()(64bit) for package: 32:bind-utils-9.9.4-37.el7.x86_64
--> Processing Dependency: libisccfg.so.90()(64bit) for package: 32:bind-utils-9.9.4-37.el7.x86_64
--> Processing Dependency: liblwres.so.90()(64bit) for package: 32:bind-utils-9.9.4-37.el7.x86_64
--> Running transaction check
---> Package bind-libs.x86_64 32:9.9.4-37.el7 will be installed
--> Processing Dependency: bind-license = 32:9.9.4-37.el7 for package: 32:bind-libs-9.9.4-37.el7.x86_64
--> Finished Dependency Resolution
Error: Package: 32:bind-libs-9.9.4-37.el7.x86_64 (rhui-REGION-rhel-server-releases)
           Requires: bind-license = 32:9.9.4-37.el7
           Installed: 32:bind-license-9.9.4-38.el7_3.noarch (@rhui-REGION-rhel-server-releases)
               bind-license = 32:9.9.4-38.el7_3
           Available: 32:bind-license-9.9.4-14.el7.noarch (rhui-REGION-rhel-server-releases)
               bind-license = 32:9.9.4-14.el7
           Available: 32:bind-license-9.9.4-14.el7_0.1.noarch (rhui-REGION-rhel-server-releases)
               bind-license = 32:9.9.4-14.el7_0.1
           Available: 32:bind-license-9.9.4-18.el7.noarch (rhui-REGION-rhel-server-releases)
               bind-license = 32:9.9.4-18.el7
           Available: 32:bind-license-9.9.4-18.el7_1.1.noarch (rhui-REGION-rhel-server-releases)
               bind-license = 32:9.9.4-18.el7_1.1
           Available: 32:bind-license-9.9.4-18.el7_1.2.noarch (rhui-REGION-rhel-server-releases)
               bind-license = 32:9.9.4-18.el7_1.2
           Available: 32:bind-license-9.9.4-18.el7_1.3.noarch (rhui-REGION-rhel-server-releases)
               bind-license = 32:9.9.4-18.el7_1.3
           Available: 32:bind-license-9.9.4-18.el7_1.4.noarch (rhui-REGION-rhel-server-releases)
               bind-license = 32:9.9.4-18.el7_1.4
           Available: 32:bind-license-9.9.4-18.el7_1.5.noarch (rhui-REGION-rhel-server-releases)
               bind-license = 32:9.9.4-18.el7_1.5
           Available: 32:bind-license-9.9.4-29.el7.noarch (rhui-REGION-rhel-server-releases)
               bind-license = 32:9.9.4-29.el7
           Available: 32:bind-license-9.9.4-29.el7_2.1.noarch (rhui-REGION-rhel-server-releases)
               bind-license = 32:9.9.4-29.el7_2.1
           Available: 32:bind-license-9.9.4-29.el7_2.2.noarch (rhui-REGION-rhel-server-releases)
               bind-license = 32:9.9.4-29.el7_2.2
           Available: 32:bind-license-9.9.4-29.el7_2.3.noarch (rhui-REGION-rhel-server-releases)
               bind-license = 32:9.9.4-29.el7_2.3
           Available: 32:bind-license-9.9.4-29.el7_2.4.noarch (rhui-REGION-rhel-server-releases)
               bind-license = 32:9.9.4-29.el7_2.4
           Available: 32:bind-license-9.9.4-37.el7.noarch (rhui-REGION-rhel-server-releases)
               bind-license = 32:9.9.4-37.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
  • Why are you trying to install that specific version? Why not just yum install bind-utils? Have you added any 3rd party libraries to the system? – jordanm Dec 6 '16 at 5:06
  • I am just trying to yum install bind-utils. – Drakes Dec 6 '16 at 15:31
1

I ran into this issue as well and found it was a specific package version. In file /etc/yum.repos.d/redhat-rhui.repo under [rhui-REGION-rhel-server-optional] I added the line: exclude=32:bind-devel-9.9.4-50.el7_3.1.x86_64

Block your version and section accordingly.

-1
rpm -e --nodeps bind-libs-lite bind-license
yum install bind-utils

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.