3

Today, I started having most web sites failing to load in browsers. Checking my network settings, I discovered those strange settings in ipv6 tab: buggy configuration

Switching back to my usual dns for ipv6 (Google's one, 2001:4860:4860::8888 and 2001:4860:4860::8844) solved my browsing issue.

But just to make sure, I then reopened the network settings: the same strange ipv4 addresses in my ipv6 dns configuration were back! Networking still works for now, but I fear the trouble will come back on next reboot.

The ipv4 tab has its expected settings.

The /etc/resolv.conf file was pointing my isp own ipv6 dns server, I have removed them.

resolvconf package is not installed.

/etc/NetworkManager/system-connections/Wired connection 1 file looks fine.

[ethernet]
duplex=full

[connection]
id=Wired connection 1
uuid=231ba09e-7c56-4fb3-9df2-37cc0c4202b0
type=ethernet
timestamp=1480972453

[ipv6]
method=auto
dns=2001:4860:4860::8888;2001:4860:4860::8844;
ignore-auto-dns=true
ip6-privacy=2

[ipv4]
method=auto
dns=8.8.8.8;8.8.4.4;
ignore-auto-dns=true

nm-connection-editor interface shows the right settings.

/etc/dhcp/dhclient.conf file does not contain any supersede.

Only the network configuration applet is wrong. I guess it is the network-manager-gnome interface. Its version on my system is 0.9.10.0-2 according to synaptic.
My distribution is a Debian Jessie, unattended updates activated (stable channel of course, it would not be a Jessie anymore otherwise, backports enabled), using gnome.

I search a bit randomly in my hidden home folders if some local settings were related to networking just in case, but found nothing, including in ~/.gconf/ folder.

What else should I check for that issue please?

Follow up:

Thanks sourcejedi,
So the bad display looks like a bug, ipv6 addresses being displayed here as ipv4, using only first four bytes of them. Maybe this is just a display bug. But redefining my settings as I have done would then have overwritten the actual cause of the trouble...
I have reboot now, things still works for now (with display bug still here). No clue what was the actual trouble.
(Emptying the resolv.conf as I have done was undone at the next boot by the way, it was refilled with my isp ipv6 dns.)

Checking the nmap version on my system, it is 6.47-3+deb8u2. But anyway, the old bug you found about it does not look related, just similar as you say.

  • 2
    Note this address is the first 4 bytes of the IPv6 address used for the DNS server. (I googled the IPv4 address, which revealed a similar issue with nmap seclists.org/nmap-dev/2010/q2/899). – sourcejedi Dec 5 '16 at 22:29
  • Yeah, you are right. I was wondering if those invalid ipv4 addresses in ipv6 setting were the truncated ipv6 ones, but I got too lazy to remember ipv6 was in hex notation and have not performed the conversion... – Frédéric Dec 5 '16 at 22:46
  • Seeing this bug in Ubuntu GNOME 16.10 so it seems it's still not fixed. Does anyone know if it has even been (officially) reported yet? – RavanH May 4 '17 at 21:30
  • It looks like it has been reported to Red Hat then closed un-handled (end of life of distro for which it was reported). – Frédéric May 5 '17 at 11:30
0

I finally found a likely cause. I was having rdnssd installed. This packing has a know bug which causes it to override the dns settings...

I have removed it.

sudo apt-get remove rdnssd

As already later stated in the question, the bad display was just a bad display, not the actual cause of the trouble.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.