6

On Fedora 24, setting a compose key was easy, the keyboard shortcuts setting was there to help.

I upgraded to Fedora 25 and now that setting changed and I can't set a compose key anymore.

Here is what it now looks like:

Fedora 25 missing Compose Key (French interface)

Is there a way to set it anyway? Even using the terminal.

PS: Please create tag.

5

You can set it with the gnome-tweak-tool. It is found under the typing tweaks. The gnome-tweak-tool is easily installed with the gnome-software application.

  • 2
    It is found under Typing => Position of Compose Key. I would recommend Right Alt if you have the physical key. I can't believe this is not available in standard Gnome though. – eregon Apr 30 '17 at 12:11
0

First, you need to find the compose key you want to set. You can get the list with the command:

$ grep "compose" /usr/share/X11/xkb/rules/base.lst

Then, in /etc/X11/xorg.conf.d/00-keyboard.conf (Exact file may vary), add the line:

Option "XkbOptions" "<compose-key-code>"

in the InputClass section.

Example for me:

Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "ch"
        Option "XkbVariant" "fr"
        Option "XkbOptions" "compose:rctrl"
EndSection

Reboot (or at least # pkill X) is required.

Source

0

. Go to gnome tweak tool

. Then select typing left menu

. Expand Position of Compose Key and select the key that best suites you. it was right Alt in my older fedora

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.