1

I just got a new ZTE Phone and I'm trying to connect it to my PC via USB. I'm running Fedora 24 and mostly need to connect the phone for USB file transfer as well as app development using Android Studio.

There is a connection-mode on the phone that says "Install drivers", which displays the phone as a USB drive with a few .exe files, but they fail to open/run (I guess they are Windows drivers).

As a next step I tried to add a udev rule using the idVendor and idProduct that were returned by lsusb (19d2:0241), I set the group to plugdev and the mode to 0664. This still didn't solve the problem (my old phone worked fine after adding an udev rule).

adb devices returns a0b14f8b no permissions. I'm a bit puzzled as to where to find the appropriate drivers and make the USB connection work.
Any suggestions?


EDIT: the exact model of the Phone is ZTE Axon Elite Gold 5.5inch 32GB

0
2

Turn on Developer Option:

First, open up your Settings app.
Scroll all the way down to find “About phone” (or “About Tablet”)
Scroll down again and find the entry with the Build number.
Start tapping on the “Build number section”, Android will now pop up a message informing you that in x amount of clicks you will become a Developer. Keep tapping until the process is complete.

Once you got it turn on USB Debugging. Switch to MTP mode and you should accept the fingerprint of certificate on your android device. Cheers

1
  • Good stuff, MTP did the job, thx!
    – mattu
    Apr 6 '17 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.