0
root@Kali:~# uname -r

4.6.0-kali1-amd64

root@Kali:~# apt-cache search linux-headers

aufs-dkms - DKMS files to build and install aufs

linux-headers-4.8.0-kali1-all - All header files for Linux 4.8 (meta-package)

linux-headers-4.8.0-kali1-all-amd64 - All header files for Linux 4.8 (meta-package)

linux-headers-4.8.0-kali1-amd64 - Header files for Linux 4.8.0-kali1-amd64

linux-headers-4.8.0-kali1-common - Common header files for Linux 4.8.0-kali1

linux-headers-4.8.0-kali1-common-rt - Common header files for Linux 4.8.0-kali1-rt

linux-headers-4.8.0-kali1-rt-amd64 - Header files for Linux 4.8.0-kali1-rt-amd64

linux-headers-amd64 - Header files for Linux amd64 configuration (meta-package)

linux-headers-rt-amd64 - Header files for Linux rt-amd64 configuration (meta-package)

linux-libc-dev-alpha-cross - Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-arm64-cross - Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-armel-cross - Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-armhf-cross - Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-hppa-cross - Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-m68k-cross - Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-mips-cross - Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-mips64-cross - Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-mips64el-cross - Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-mipsel-cross - Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-powerpc-cross - Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-powerpcspe-cross - Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-ppc64-cross - Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-ppc64el-cross - Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-s390x-cross - Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-sh4-cross - Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-sparc64-cross - Linux Kernel Headers for development (for cross-compiling)

The fglrx installation always says:

 "requires that the system have kernel headers.  /lib/modules/4.6.0-kali1-amd64/build/include/linux/version.h cannot be found on this system"

Could anyone help me fix it ?

  • sounds like kali doesn't provide a compatible kernel in the repos you are using, check other available kali repos perhaps backport or testing repos. If all else fails, compile a custom kernel. – mikejonesey Dec 3 '16 at 19:38
1

You should install the latest linux image and headers, run apt-get search linux-image then install it:

apt-get install linux-image-4.8.0-kali1-amd64
apt-get install linux-headers-4.8.0-kali1-amd64

Restart your system and boot the 4.8 kernel version , then install fglrx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.