0

last night I installed the updates for Linux Mint 17.1 from the updates manager. I hadn't installed them for a couple weeks but I was about to do something on the internet where I wanted to make sure I had the latest security updates. It told me it would install a new Nvidia driver (I think it was something like 367) as well as a couple other packages. I clicked okay, and then it downloaded and installed for about three minutes. When it was done, it said it was unable to update Firefox (this is a problem I have never had before). I closed it and my computer continued to work just fine.

However, when I tried to boot my computer this morning, it said it was missing a chipset and then just had a spinning loading cursor forever. I tried rebooting and it did the same thing.

Any idea on how to recover from this? I have a massive project I'm working on that I don't want to loose all my data from (although I do have a backup from about a week ago...)

  • 1
    use a bootable usb stick to boot up and from there you can get your projects... in a good condition.. – sanjeev Dec 3 '16 at 18:40
  • @SanjeevPrasadThakur Can you explain how to do that? Thanks! – Anson Savage Dec 3 '16 at 18:43
  • do you have a live bootable usb ??? – sanjeev Dec 3 '16 at 18:48
  • @SanjeevPrasadThakur No, but I can make one. Does it need to be the same operating system? – Anson Savage Dec 3 '16 at 18:49
  • 1
    oh not at all it may NOT be the same os... but should have a linux operating system.. (may be options are available in OS other than linux os but i don't know about that other options...). you have to make a bootable usb stick... with live options... – sanjeev Dec 3 '16 at 18:52
1

Boot your system , from GRUB menu choose "Advanced option for linux mint" , then choose a working kernel version (do not choose the first one)

edit

From the terminal list the latest changes through cat /var/log/apt/history.log you will get something like:

Start-Date: 2016-12-03  .....
Commandline: e,g:  /usr/bin/unattended-upgrade , apt install somepackages ,/usr/sbin/synaptic ,
Requested-By: user...
Install: ...
End-Date ....

Verify the list of the latest upgraded package, first uninstall the new installed Nvidia driver then reboot , if doesn't work maybe you need to uninstall some other packages (e,g: a backported package)

  • Okay, I got into GRUB, but there are no advanced options... – Anson Savage Dec 3 '16 at 20:13
  • Okay, sweet! I'm trying it out now. – Anson Savage Dec 4 '16 at 1:46
  • Okay, so I've got to the log, which looks great, but is there anyway to revert a package rather than uninstall it? – Anson Savage Dec 4 '16 at 2:03
  • 1
    @AnsonSavage First uninstall the nvidia driver , after rebooting successfully ,reinstall the driver, Check for update , Verify the list of package from the update manager , if there an update for the driver un-check it maybe the problem the problem come from the level 3 , 4 or 5 – GAD3R Dec 4 '16 at 11:05
  • 1
    Hey, thanks for the help! I fixed it using this tutorial: forums.linuxmint.com/viewtopic.php?t=122257 – Anson Savage Dec 6 '16 at 1:19
0

use a bootable usb stick to boot up and from there you can get your projects... in a good condition..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.