0

I have 2 SSDs, one with Windows 10 (sdd) and one that hopefully will have Linux Mint (sdc) on. I also have 2 HDDs that are in a raid array but this is exclusively for windows really and shouldn't really interfere.

I'm working with a bootable USB stick. I go into the OS then go to install Mint. Everything seems to run fine then nearer the end the bootloader issue arises.

Executing 'grub-install /dev/sda' failed. Fatal Error.

The sda bit is what throws me. I've used linux a lot in the past but never understood the whole bootloader/grub scenario. I think the main issue is that in the past I've had Ubuntu on a HDD and set up EasyBCD to choose OS at boot rather than grub. I removed the Ubuntu drive and in it's place is an empty SSD as mentioned before. I uninstalled said EasyBCD but it's still showing the same boot up menu even after installation. Where should I be putting my bootloader? I want to dual boot Windows and Mint with them being on seperate drives.

There is also an option to install alongside Windows 10 but I assume that it'll put Mint on the same drive as the Windows one. So I normally go for 'erase everything' and then select the drive I want for Mint (sdc). Any thoughts or advice is welcome. I'm sure there've been a million questions like this but I couldn't find anyone that matched up with my problem.

  • BIOS or UEFI? MBR or GTP partition table(s)? – AlexP Dec 3 '16 at 16:06
  • I used rufus to make the bootable usb. There I chose the option 'MBRfor BIOS and EUFI'. Thinking that would be the catch all option. I'm assuming you tink this is where the problem originates from? What option should I pick instead? – shmink Dec 3 '16 at 16:09
  • The computer, not the bootable stick. Is it using BIOS or UEFI boot? The hard disks are they GTP or MBR? In general whenever you have a out-of-the-ordinary setup (multiple hard disks etc.) you should chose "Something else" in the installer and specify partitions explicitly; this also allows you to specify explicitly where you want GRUB to be installed. If your computer allows you to chose sdc as a boot device, the put GRUB on sdc. – AlexP Dec 3 '16 at 16:17
  • Apologies. My computer is UEFI as for the disks I've no idea now but I'll find out. Is this likely to have the caused the issue? As I mentioned it seems to install everything fine till the grub bit. Are you saying I should put the grub on the same drive I install mint onto? I'll be sure to do it, just want to be clear. Thanks for the help so far. – shmink Dec 3 '16 at 16:47
  • GRUB must be installed (as in grub-install) on a disk which the computer allows you to select as a boot device. For a quick test, just perform a straightforward installation and install GRUB on the same disk as Mint, then try to boot from that disk. – AlexP Dec 3 '16 at 16:50
0

Whenever you have a out-of-the-ordinary setup (multiple hard disks etc.) you should chose "Something else" in the installer and specify partitions explicitly; this also allows you to specify explicitly where you want GRUB to be installed. If your computer allows you to chose sdc as a boot device, then put GRUB on sdc, that, the disk on which you install Mint.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.