8

For some reason my Fedora 25 FRESH install is not using wayland by default. I know this because of

$: loginctl show-session 3 -p Type
Type=x11

If I was using Wayland by default that should say wayland or weston. I'm very confused why this fresh install of fedora 25 is not sporting wayland by default. I looked over the arch wiki briefly, and tried to test run wayland by issuing

$: weston

Also, I have rebooted fedora to multiuser.target, to get just a command line to manually launch a dbus-run-session for wayland, and this is the output:

$: dbus-run-session -- gnome-shell --display-server --wayland
(gnome-shell:1372): mutter-WARNING **: Can't initialize KMS backend: could not find drm kms device

Then I tried:

$: startx

And my standard gnome desktop popped up no problem. I'm seriously wondering if fedora 25 live installer ever installed wayland to begin with?

After looking for the wayland config file weston.ini, I cannot find it in ~/.config/ where it's supposed to be.

System info:

$:uname -a
Linux sark 4.8.10-300.fc25.x86_64 #1 SMP Mon Nov 21 18:49:16 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

I have done a full system update on first login with

$: sudo dnf update
  • Also went through the process of using the nvidia drivers for my graphics card; GTX 950
  • Not using the default pre-my-move-to-nvidia-driver driver :P

EDIT:

After investigating onto my laptop, my Laptop reports that it is using wayland:

$: loginctl show-session 2 -p Type
Type=wayland

This laptop was a fedora24 upgrade to fedora25, not a fresh install of fedora 25

Laptop info:

$: uname -a
Linux mcp 4.8.10-300.fc25.x86_64 #1 SMP Mon Nov 21 18:59:16 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
  • Just to clarify: you are using GNOME desktop, right? – hugomg Dec 3 '16 at 3:10
  • Yes, I am. $: gnome-shell --version #reports GNOME Shell 3.22.2 @hugomg – enconn Dec 3 '16 at 3:12
  • Do you have a nvidia-card with closed-source-driver? – user192526 Dec 3 '16 at 12:26
  • @Bahamut Yes, I'm using the Nvidia 375.20 driver from their website. – enconn Dec 3 '16 at 14:35
11

Nvidia does not yet support Wayland, so Fedora 25 falls back to X11. From the Nvidia forum I see someone has used packages from the in-development Fedora 26 plus some patches to get it working, but notes "I have tested it with local builds and it runs like crap, personally I wouldn't bother trying it in F25."

Hopefully this will be resolved for F26. In the meantime, I'm at least glad that the X11 fallback worked nicely and transparently.

  • Was this supposed to be resolved now that F26 is out? I am on a fresh F26 with a GTX 770 and it's not defaulting to Wayland either. What about F27? – comfreak Oct 22 '17 at 22:26
  • 1
    No Wayland yet. Ask Nvidia, I'm afraid. – mattdm Oct 22 '17 at 22:30
1

If you're on the nvidia drivers, check that nouveau is properly blacklisted on the kernel args.

$ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-4.8.16-300.fc25.x86_64 root=UUID=b13dad5b-d34b-4d50-acae-6c28143961b3 ro nouveau.modeset=0 rd.driver.blacklist=nouveau rhgb quiet 

I've had this exact same issue, using an Optimus laptop WITH nouveau, and finally solved it by installing bumblebee-nvidia. Which as per 375.26-1.fc25 does support Wayland.

Actually, upon reboot there was a kernel-devel mismatch and nvidia module wasn't loaded. However nouveau had been blacklisted. And wayland was working again! Properly upgrading my kernel made everything fall into place (nvidia & bbwsitch loaded, wayland still working!).

So try blacklisting nouveau maybe?

0

Try Boot-parameter nvidia-drm modeset=1 sources nvidia site

  • after setting that with mod probe, then booting down to multiuser.target and attempting to run the dbus session of gnome shell and Wayland. It gave the same error as before: (gnome-shell:1372): mutter-WARNING **: Can't initialize KMS backend: could not find drm kms device – enconn Dec 3 '16 at 14:59
  • This probably isn't anything, but I get a completely different error when I attempt to run that dbus command I get a completely different warning: (gnome-shell:2304): mutter-WARNING **: Can't initialize KMS backend: Could not take control: GDBus.Error:System.Error.EBUSY: Device or resource busy – enconn Dec 3 '16 at 15:03
  • I also verified with loginctl that my desktop is still using x11 after mod probe and restart. – enconn Dec 3 '16 at 15:06
  • 1
    Did some looking around and found this "Fifth step has been Jonas Ådahls work on enabling the binary NVidia driver for Wayland. He has put together a set of patches to be able to support NVidias EGLStreams interface, which means that starting from Fedora Workstation 25 you will be able to use Wayland also with NVidias binary driver." - blogs.gnome.org/uraeus/2016/11/01/… the patches they link to are here - github.com/jadahl/mutter/tree/wip/egldevice It doesn't look like this made it in for fedora25 release by looking at the git page. – enconn Dec 3 '16 at 15:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.