I have a Syba SI-PEX-40064 SATA adapter I am trying to install on a Slackware box with a ASRock G41M-S3 motherboard. After boot, I can see the interface with lspci, but it doesn't seem to have been recognized according to syslog and messages.

The Slackware version is 14.0

Any pointers on where I can get info to debug this?

  • If you don't get a reply here, you might try the official Slackware forums: linuxquestions.org/questions/slackware-14 Pat himself hangs out there. Dec 3 '16 at 4:34
  • I posted in the hardware section. I have been updating a thread as I dig further. I probably show my stupidity that way, but at least if someone else gets a similar problem they might get some ideas. Thanks.
    – mongo
    Dec 3 '16 at 17:56
  • @mongo did you solve your problem? I have the same pci-e card 4 years ago and I have problems like hard resetting link... Oct 31 '17 at 21:56
  • @EmilioLazo, I did resolve the problem, after I bought more SATA adapter cards, but it was not what I described here. However a couple of people who asked me about it found that my solution worked in their instance, which they too had not properly diagnosed. So I posted the answer below, recognizing that it is not exactly responsive to the question.
    – mongo
    Oct 31 '17 at 23:43

I solved the problem. It turns out that the SATA gets lined up first in the drive list (sda, etc.) on that motherboard when it is used, and the MB is first when no adapter card is used.

This was confusing, but once I realized it, I needed a solution to specify a specific drive, no matter what the drive was called in a given boot.

So I had to specify the drive I wanted to boot off of which might be sda with no adapter and sde with the adapter. Using a UUID specification allowed a consistent reference to the disk that I wanted to boot off of.

My original post is not exactly accurate as to what was happening, however others have had similar problems and emailed me on other sites, and indicated that the UUID specification worked for them. So I understand that the question is disjoint from the answer, but I have addressed this in the interest of helping others similarly situated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.