1

I'm new to Kali but I realy want to get into this so I tried some online tutorials refering to aircrack-ng.

I am using 2 interfaces which are my wifi and a networkadapter (it's connected to the same WiFi than the first interface). However, everytime im using airmon-ng start [networkname] it keeps disconnecting my WiFi. could that be because of an invalid networkcard? or maybe because of the managed mode?

  wlx00223f942bc4  IEEE 802.11bgn  ESSID:"JIxx0Ovqee1j"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 08:76:FF:CB:C4:21   
          Bit Rate=18 Mb/s   Tx-Power=30 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=70/70  Signal level=-40 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:1  Invalid misc:23   Missed beacon:0



wlp3s0    IEEE 802.11bgn  ESSID:"JIxx0Ovqee1j"  -->home wifi
          Mode:Managed  Frequency:2.462 GHz  Access Point: 08:76:FF:CB:C4:21   
          Bit Rate=18 Mb/s   Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=56/70  Signal level=-54 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:145   Missed beacon:0

Problem (after using monitor mode):

root@sney:/home/sney# airmon-ng start wlx00223f942bc4

Found 6 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to run 'airmon-ng check kill'

  PID Name
  768 NetworkManager
  795 avahi-daemon
  829 avahi-daemon
 1000 wpa_supplicant
 1236 dhclient
 2225 dhclient

PHY Interface Driver    Chipset

phy0  wlp3s0    iwlwifi   Intel Corporation Centrino Wireless-N 2200 (rev c4)
phy1  wlx00223f942bc4 carl9170  NetGear, Inc. WN111(v2) RangeMax Next Wireless [Atheros AR9170+AR9101]
Interface 15mon is too long for linux so it will be renamed to the old style (wlan#) name.

    (mac80211 monitor mode vif enabled on [phy1]wlan0mon
    (mac80211 station mode vif disabled for [phy1]wlx00223f942bc4)
  • Please edit your question to use code formatting (the {} button up top of the editor) for blocks of terminal text. Your question is very hard to read currently... – derobert Dec 2 '16 at 19:04
  • Thanks for the quick answer! sorry, did not recognize that function. – ins8 Dec 3 '16 at 14:59
1

This is perfectly normal and there is no problem in your network card. When monitor mode is enabled, the interface switches from wlan0 to wlan0mon so as to perform monitoring, capturing the information. It means you can use only one of the interface modes. You can turn on WiFi again using the following codes.

sudo service network-manager restart
sudo ifconfig wlan0 up
  • Can u elaborate.more? After it becomes wlan0mon my laptop is no longer connected to my ssid. Do I need 2 wifi cards? Is wlan0mon still connected or not? – typelogic Feb 2 at 17:10
  • @typelogic Understand it this way. Your WiFi card can enter two modes, i.e. network mode and monitor mode. When you enter monitor mode, your wireless card cannot connect to any network as it monitors all networks. Only when you're in network mode, you can connect to your SSID. The above commands in terminal switches the mode back to network. Hence, you don't need two WiFi cards. Wlan0mon will exist only when you're in monitor mode. – Abhi Feb 5 at 5:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.