0

I set up a fully encrypted (luks on lvm on softraid-1) debian jessie with a usb-stick holding the /boot partition and lost that stick (yes, kind of funny).

I got back into the system recovery and created another /boot partition on a usb-stick. I changed the UUID in /etc/fstab and mounted it on /boot.

I ran apt-get --reinstall install linux-image-3.16.0-4-amd64 linux-headers-3.16.0-4-amd64, the same with dpkg -i and the cached package in /var/cache/apt/archives, both commands completed successfully but my /boot remains empty.

Any ideas how I could get the kernel-images on /boot? Could I just copy a boot partition from another system and update/install grub?

0

You are reinstalling a virtual package.

You need to find what package is required by linux-image-amd64, so you will find the real kernel package. Reinstall that package.

You should also reinstall grub and possibly manually do a update-initramfs to all targets.

  • I installed the specific packages with apt, clarified that in the question, sorry for forgetting that, also ran the grub-install and update-initramfs, the latter completed fine but the first complained, probably due to missing kernel – user7183174 Dec 1 '16 at 18:01
  • ok, manually fetching the depending package and installing that with dpkg solved it, I think I misunderstood your answer. Thanks for the help anyway – user7183174 Dec 1 '16 at 18:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.