1

I'm facing the same issue as many other people, but for some reason their solutions don't seem to fix my issue.

Basically I bought a TL-WN722N USB-adapter from TP-Link that I finally got delivered today. However I can't see mto get my VM to use it. I'm running VMWare pro (12.01) and am using the latest release of Kali linux as my guest OS. Might be worth adding that I've installed VM-tools too.

The guest OS does recognize the adapter, but I can't seem to get it working.

lsusb gives this:

Bus 001 Device 002: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n

So clearly the guest OS finds the USB-adapter.

But when running iwconfig I get this:

lo no wireless connectors

eth0 no wireless connectors

So it's clear that the wireless adapter is not being used.

Writing dmesg gives this:

ath9k htc: Firmware - ath9k /htc/htc 9271-1.4.0.fw download failed

I've tried everything from purging and re-installing the firmware using aptitude to removing and plugging the adapter in again after a reboot of the guest OS.

I'm not sure what other info might be necessary to help me in this issue, so please do ask if I'm missing anything.

EDIT:

I just did an sudo apt-get update and sudo apt-get upgrade after which the adapter worked.

However, a few minutes later after a reboot and extending my harddrive in VMWare the adapter is no longer working anymore. All I did was extend the harddrive and format the newly added partition from unalocated to ext4... :/

1

Only 1 thing fixed it for me: Plugging the WiFi adapter into a USB 2.0 slot.

Same adapter, same situation. My laptop at the office had Kali in a VMWare, it picked it up instantly! (VMWare even automatically attached it to the VM the first time I plugged it in!) Came home, plugged it into my workstation with the same setup, VMWare + Kali, nothing. I can find the it via lsusb, but iwconfig wasn't having it. After trying a few different things, there was a random website that recommended trying USB2.0 instead. Sure enough!

Hope that works for you!

  • Unbelievable! All the detailed guides and videos I saw, while all I had to do was change the friggin port! Thanks a lot man. I love this community! – SuperNOVA Feb 23 '17 at 2:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.