18

I am having this weird issue where I can't make TeamViewer to work meaning I am getting this error (check image below) and therefore I can't connect to any remote PC:

TeamViewer not ready. Please check your connection

enter image description here

At office others developers using Ubuntu and Windows 7/10 are able to use TeamViewer without problems so I am not sure what the problem is. I have checked the firewall status and isn't running:

$ service firewalld status
Redirecting to /bin/systemctl status  firewalld.service
● firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; disabled; vendor preset: enabled)
   Active: inactive (dead)
     Docs: man:firewalld(1)

I have checked SELinux status and it's disabled:

$ getenforce
Disabled

I have Internet connection since I am opening this post from the PC where the problem with Teamviewer is happening. Maybe is something related to this other issue I am having but I can't be sure at all. I have checked some docs on Internet like this one but that's not my problem so ... any help?

Note: If you need anything from my side (debug info) let me know and I'll add as part of the OP. Also I am not sure if this post should be on this community but I believe the problem is coming from my Linux and not from Teamviewer itself.

Update:

After follow the suggestion from @phg I am still researching the issue and I have found this. Apparently is an issue with Wayland and it's not fixed yet and it happen only on Fedora 25. We need to wait on a fix from Teamviewer team.

Update 1 (01/27/2017):

There is a workaround where you can use the tarball non supported file and it works, I've already test it but this approach has a problem since Teamviewer doesn't run as a service and therefore you can't add the PC where it's running to your "computers & contacts" (very useful). Maybe there is a way to make the executable to run as a service but I didn't try this part, if anyone could try and leave an answer around will be good for newcomers.

  • 1
    What does the journal say? What do strace, valgrind, tcpdump etc. report? Btw. since Teamviewer is a commercial product you might want to ask the vendor first. – phg Dec 1 '16 at 15:55
  • Are you using TeamViewer from a remote session like x2go or RDP ? I got the same issue when using it remotely, running in a Virtual Machine. – ob2 Sep 16 '17 at 22:01
1

Your laptop has internet connection, everything else is working except teamviewer. In this situation it's expected that something blocking teamviewer from accessing internet.

Please install iptables & check your firewall rules as follows

sudo dnf install iptables    
sudo iptables -S

Save your existing iptable rules as follows for future use.

sudo iptables-save 

Now flush all iptables rule

sudo iptables -F
sudo iptables -X   

After flashing all rules output of "sudo iptables -S" shall look like

-P INPUT ACCEPT
-P FORWARD ACCEPT
-P OUTPUT ACCEPT

Now again check teamviewer. If it still not working you've to determine exactly over what port it's trying to communicate.

I use the tool "tcptrack". It's in rpmforge repository which is not a recomended to add. Search .rpm file in google and install it. Otherwise clone this git https://github.com/bchretien/tcptrack.git and build it. If your internet adapter is "eth0" use the following to track packets.

sudo tcptrack -i eth0

Close teamviewer. Now keep the tcptrack terminal open in one side and again open teamviewer. Check what ports teamviewer is opening. Check whether your ISP allow those ports etc.

Latter you may restore saved iptable rules after necessary edits (if any) with "iptables-restore" command.

EDIT Once I had the same problem. The Linux Teamviewer client open a connection with destination port 5938. My firewall rules ware blocking unrelated connection with --dport 5938. In case tcptrack is not suitable, you may use iptraf-ng also. It's present in base repository, install and use as follows

sudo dnf install iptraf
sudo iptraf-ng
0

I observed the same problem (ubuntu 18.04 and TeamViewer 14.5)

Starting the TeamViewer-Daemon on the commandline with sudo helped.

  1. stop/kill the currently running teamviewer instance
  2. start the daemon with:

    sudo teamviewer --daemon enable ... the console output is something like:

    Action: Installing daemon (14.5.1691) for 'systemd' ...
    installing /etc/systemd/system/teamviewerd.service (/opt/teamviewer/tv_bin/script/teamviewerd.service)
    Try: systemctl enable teamviewerd.service
    systemctl start teamviewerd.service
  1. start teamviewer as normal (maybe logout and login again, if your license is not recognized

(I read about it here: https://forum.manjaro.org/t/teamviewer-beta-13-not-ready-please-check-connection/37638)

protected by Community Dec 6 '16 at 15:42

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.