1

I just downloaded dotfiles (https://github.com/skwp/dotfiles) and don't understand the tmux config:

# Create splits and vertical splits
bind-key v split-window -h -p 50 -c "#{pane_current_path}"
bind-key ^V split-window -h -p 50 -c "#{pane_current_path}"
bind-key s split-window -p 50 -c "#{pane_current_path}"
bind-key ^S split-window -p 50 -c "#{pane_current_path}"

Pressing v anywhere doesn't split the window when I am in a tmux session. What else am I supposed to press?

closed as off-topic by jasonwryan, techraf, countermode, Satō Katsura, Archemar Dec 1 '16 at 9:21

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – jasonwryan, techraf, countermode, Satō Katsura, Archemar
If this question can be reworded to fit the rules in the help center, please edit the question.

  • I'm not 100% sure, but if you press ^b (CTLR + B) - to enter tmux "mode", then the bind-key. For example, ^b followed by v should be the first option on the list. I'm not sure if ^V is CTLR+V or CTLR+SHIFT+V. – Tigger Dec 1 '16 at 5:07
  • none of those worked for me unfortunately – Edmund Dec 1 '16 at 5:09
  • ohhhh i know why, they had this in the file unbind C-b set -g prefix C-a it worked!!! CTRL + A and then v – Edmund Dec 1 '16 at 5:09
  • ^a (or CTLR+A) was the mode key combo for screen, which is a similar but older program to tmux. I guess someone liked the old screen key combo. – Tigger Dec 1 '16 at 5:13
1

In my tmux.conf:

bind | split-window -h

bind "-" split-window -v

For splite, un push CTRL+B and after CTRL+- ou CTRL+|

So i think for you CTRL+B and CTRL+v

Not the answer you're looking for? Browse other questions tagged or ask your own question.