8

So i am trying to install genymotion on ubuntu 16.04 and i need the modules running so i open up virtualbox, i get some warnings

so i reinstalled virtualbox-dkms and i checked my headers which i got

    (cloudyjr)volt@localhost:~$ uname -r 
    3.8.11

for some reason dkms is not detecting my headers. So after that i move on and i try to launch a Vm ignoring the warning and i get

output

So i go ahead and i try out what it says

    sudo modprobe vboxdrv
    modprobe: ERROR: could not insert 'vboxdrv': Operation not permitted

And now i am stuck Help ME PLEASEEE!!!!?????????

1
  • 1
    Go to BIOS and OFF the Secure Boot option. Oct 18, 2019 at 12:23

3 Answers 3

13

I know that this question is too old, but because there is no accepted answer and none of these answers solved the issue in my case; I am writing how I solved this today:

When running this command, get this error:

$ sudo modprobe vboxdrv
modprobe: ERROR: could not insert 'vboxdrv': Required key not available

The problem is that the module is not signed and therefore not loaded with the kernel. This will happen if your computer has the SecureBoot mode activated, something very common in modern equipment.

That's why I get this error opening any machine in the virtual box

Kernel driver not installed (rc=-1908)

Do the following steps to sign a driver, and it is loaded as a kernel module, on Ubuntu systems and also on Debian 9:

1. Install the mkutil package to be able to do signed.

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install mokutil

2. generate the signature file:

openssl req -new -x509 -newkey rsa:2048 -keyout MOK.priv -outform DER -out MOK.der -nodes -days 36500 -subj "/CN=VirtualBox/"

3. Then add it to the kernel:

sudo /usr/src/linux-headers-$(uname -r)/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n vboxdrv)

4. Register it for the Secure Boot.

IMPORTANT! That will ask you for a password, put the one you want, you will only have to use it once in the next reboot.

sudo mokutil --import MOK.der

5. Finally, restart the computer. A blue screen will appear with a keyboard wait, press the key that asks you to interrupt the boot.

enter image description here

When you are inside the blue screen, select Enroll MOK > Continue > and it will ask you for the password that you have previously entered, you will enter it and you will be informed that the operation has been completed successfully.

Now your operating system will start and you can now use VirtualBox without problem :)

Hope this help someone.

3
  • This worked for me. Thank you very much Aug 14, 2020 at 14:25
  • I've tried this but I'm not getting the blue screen with the options on boot.
    – bob
    Oct 18, 2021 at 3:00
  • Thx a lot. Not sure, but this should be also part of the install instructions of VB.
    – eddy147
    Nov 18, 2021 at 10:36
0

Sounds like you are referencing the same issues in this post as well: VirtualBox Kernels are not working

I think I understand your issue more clearly now. Your kernel version is from a lower release:

This is for an older release but should update your kernel to the Ubuntu 16.04 version: https://askubuntu.com/questions/364156/ubuntu-13-10-kernel-still-3-8-0-31-generic

1
  • Edit your question and post dkms status and dpkg -l | egrep 'linux-generic|linux-image|linux-headers|virtualbox'
    – user192526
    Dec 1, 2016 at 9:07
0

I have just found this issue on Ubuntu 20.04. This problem can be caused by installing Ubuntu without secure boot. Unfortunately secure boot is a requirement if you want to use VirtualBox due to the closed-source kernel module required. In my case I resolved it by reinstalling Ubuntu.

If you want to use VirtualBox, during the installation procedure there is a question about restricted 3rd party libraries. You need to select this option and then beneath that, select to enable secure boot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .