1

the tilde in the PS1 appears darker on the 10.18.1.30 server. The oranges looks wrong too as do the greens, which is the most obvious. It seems both servers have no problems showing 256-colours, though some seem missing, like the 1;30m grey so not really sure why this is occurring, the one with the wrong colours is a RHEL7 server that I am now configuring, while the one with the correct colours is RHEL5 server that I am retiring.

updated graphic:

updated

Previous problem

migrated from serverfault.com Nov 30 '16 at 21:04

This question came from our site for system and network administrators.

  • 2
    First thing I would compare is coloretest-256 on both machines. And the second thing is that you most likely have different color configuration in one putty session than in the other. Look in the putty-session configuration under Window->Colours. Because I can already see that you have a difference in how bold font is printed. Which you find under the same setting window. – Hurrdurrfurr Nov 30 '16 at 17:38
  • I updated my answer. Maybe you can fix the last difference in color. But it could also be that the different font families make the color look different. – Hurrdurrfurr Nov 30 '16 at 23:25
0
  1. Open putty
  2. Load a stored session
  3. In the left pane select Window->Colours
  4. Compare the selected option under "Indicate bolded text by changing"
  5. Use the same setting across your sessions

Or do whatever you like, now that you know what's causing this :)

enter image description here

Edit:

If you still have color differences, check the "Terminal-type string" under Connection->Data and make sure they are the same. In putty I either use xterm (the default) or putty-256 if it is available in ls -lR /usr/share/terminfo/ | grep putty. Can't really explain why, tho. I just figured out this works best for me when I want good colors.

Oh and I noticed you have different fonts, that could explain why the colors look slightly different.

  • 1
    Not sure why this got downvoted because one session was the font, and the other session was the colour. the one that seems more correct, at least the one i was more used to, the older server was the colour. I will add a new result above. name on the prompt the green seems slightly off but fine enough for me. – Jon Weinraub Nov 30 '16 at 21:21
0

Check TERM environment on both shells:

echo $TERM

This difference caused by two different mechanism to create in between colors. The left one has a full 256+ colors palette, while on the right only 16. The workaround for brighter colors is to display them with bold fonts. Look carefully: on the right every similar color is exacatly the same, while the thickess was doubled. And doubling black is still black.

Try set the same TERM for the 2 boxes, and check for correct terminfo at /usr/share/terminfo.

  • both TERM shows 256, but using putty rather than xterm-256 on the putty term. so it seems the colour palette is 256 but the bold is odd. – Jon Weinraub Nov 30 '16 at 21:20
  • then check terminfo for differencies. – Ipor Sircer Nov 30 '16 at 21:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.