0

I'm trying to install graphviz version 2.38 on my RHEL workstation. I saved graphviz-rhel.repo in /etc/yum.repos.d as instructed, but when I run sudo yum list available 'graphviz*', the only version it finds is 2.30, which has a bug that has been fixed in later versions so I need to have 2.38. I think the links in graphviz-rhel.repo might be broken which is why yum doesn't find the latest stable packages, but I'm not 100% sure. Thank you.

5
  • What is your RHEL workstation version? The version depends ond this. The repo files uses $relesver in the path. Some releasever only get older versions... – Tobias Nov 30 '16 at 21:35
  • Other idea: Did you du a yum update before searching? – Tobias Nov 30 '16 at 21:36
  • @Tobias yum update upgrades packages, it's not the same as apt-get update. – jordanm Nov 30 '16 at 23:18
  • You are right. I just wanted to ensure, that the repositories are refreshed. Better would be yum makecache. – Tobias Dec 1 '16 at 6:06
  • Did you enable the repo? – Tobias Dec 1 '16 at 6:07
0

Use yum repolist all to see all repos. Use then yum-config-manager --enable repository-id to enable your graphviz repo.

If your repo is not listened try yum-config-manager --add-repo http://www.graphviz.org/graphviz-rhel.repo to add your repo.

4
  • I tried both of these. When I used yum repolist all I got a few disabled graphviz repos. Then I tried enabling them all but on the status it said 0 after the word "enabled" which I'm guessing means that it's enabled but has no packages? I confirmed this to be true by running yum list available 'graphviz*' again and the only version listed after enabling them were still 2.30. – Gustavo Rodriguez Dec 1 '16 at 16:51
  • I think the problem might be that this repo doesn't exist for my particular OS and architecture. When I type yum repolist all I get this which is caused by the graphviz-rhel.repo I added to /etc/yum.repo.d: http://www.graphviz.org/pub/graphviz/development/redhat/el7Workstation/x86_64/debug/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found – Gustavo Rodriguez Dec 2 '16 at 17:08
  • Ah. You have this version. Yes, theres is no repo for it. Check this: graphviz.org/pub/graphviz/development/redhat – Tobias Dec 2 '16 at 18:15
  • You can try the source rpm from graphviz.org. There is one for Red Hat. Howto: itechlounge.net/2012/12/… PS: I have no expereiance with this - just a tip. – Tobias Dec 2 '16 at 18:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.