0

I am trying to compile openssl 0.9.6 (I know very old version) from source on ubuntu 16.04 LTS. I did following

./configure shared --openssldir=/home/segnate/dev/openssl

make

make install

On doing make install the installation failed with error like below

installing libcrypto.so

/usr/bin/ranlib: /usr/local/ssl/lib/libcrypto.so: File format not recognized

Similar error occurred for libcrypto.so.0 , libcrypto.so.0.9.6 , libssl.so , libssl.so.0 , libssl.so.0.9.6

How do I get rid of above error?

  • 1
    are you running the installation in a 64-bit machine ? – Dababi Nov 30 '16 at 11:16
  • 1
    Don't do it (the installation). Keep it locally, and manually tell the different programs to use the old lib. Better not to mix old and new library in parallel (especially if it is an essential library, for your os) – Giacomo Catenazzi Nov 30 '16 at 14:08
  • 1
    @GiacomoCatenazzi What this error is then exactly ? – Vishvajeet Patil Nov 30 '16 at 16:54
  • 1
    @VishvajeetPatil I don't know, and the strange thing it is that it appears only on install. – Giacomo Catenazzi Nov 30 '16 at 17:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.