0

I'm not quite sure what's going on here..

I installed the EmojiOne Color SVGinOT Font from their Github page because I was tired of black & white emojis on Ubuntu, but must have made a grave error because now the entirety of Firefox is displaying only Serif font.

I ran these commands:

# 1. Download the latest version
wget https://github.com/eosrei/emojione-color-font/releases/download/v1.3/EmojiOneColor-SVGinOT-Linux-1.3.tar.gz
# 2. Uncompress the file
tar zxf EmojiOneColor-SVGinOT-Linux-1.3.tar.gz
# 3. Run the installer
cd EmojiOneColor-SVGinOT-Linux-1.3
./install.sh

Which, hoorah! Enabled me to see colored emojis! ... but also changed the entirety of Firefox to a Serif font.

argh!

araaaggh!!

I've checked the Firefox font settings and I'm fairly certain that it's not a bug on Firefox's end.

firefox font settings

Is there something I can do to sort this out? Or at least figure out what's going on? I actively despise Serif fonts and wish for it to go back to its natural sans-serif form, or at least use the default sans-serif option I gave it.

  • Firefox now comes bundled with this font, no need to use fontconfig hacks anymore – contemplator Dec 5 '16 at 6:30
1

The issue is written in their github page https://github.com/eosrei/emojione-color-font/

Setting "gfx.font_rendering.fontconfig.fontlist.enabled" on about:config to false solved for me.

[Issue #31] Some font families are not matched correctly in Linux Firefox. Workaround: Open about:config set gfx.font_rendering.fontconfig.fontlist.enabled to false. Note: May cause crashes in Firefox <48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.