Selecting the wireless network is ineffective as clicking apply results in it being deselected in favor of the other option, "do no use this device." enter image description here How Can I install the appropriate wireless drivers?

  • Install dkms and your linux headers
    – Katz
    Nov 30, 2016 at 2:29
  • @Francesc dkms is already installed if this is what you mean: community.linuxmint.com/software/view/dkms How can I install "linux headers"?
    – Dale
    Nov 30, 2016 at 2:58
  • yeah that's what i meant, you're going to need to plug in an ethernet cable for this, order to download your linux-headers and the command to install it is apt-get install linux-headers-$(uname -r) and then open software manager and search for broadcom and install broadcom-sta and broadcom-commom. Do a little bit of research on google this question has been answered before.
    – Katz
    Nov 30, 2016 at 3:07
  • @Francesc I searched software manager for "broadcom" which yielded 3 results: broadcom-sta-common, broadcom-sta-dkms, and broadcom-sta-source. I would install them, but despite using ethernet to post this the software manager is not able to access the Internet. On a different thread I tried: community.linuxmint.com/tutorial/view/796 where I learned to run a terminal command that revealed my PCI-ID is [14e4:4727], which is unsupported according to: linuxwireless.org/en/users/Drivers/b43/#supported
    – Dale
    Nov 30, 2016 at 3:59

1 Answer 1


The wl module is unsigned , you should disable the secure boot from your BIOS settings , then install the bcmwl-kernel-source :

sudo apt-get install bcmwl-kernel-source
sudo modprobe -r b43 ssb wl brcmfmac brcmsmac bcma
sudo modprobe wl
  • So I found the boot order in the BIOS but I can't find secure boot to disable it. I went ahead and ran the first line of your script - it comes back "Media change: please insert the disk labeled 'Linux Mint 16 petra - Release i38620131218 in the drive '/media/cdrom/' and press enter" This is a problem as I only have a thumbdrive.
    – Dale
    Nov 30, 2016 at 18:05
  • I googled everything I could find on sources.list and tried several of them unsucessfully. How do I open my sources.list? Please pardon my ignorance.
    – Dale
    Nov 30, 2016 at 19:41
  • deb cdrom:[Linux Mint 16 petra - Release i386 20131218]/ saucy contrib main non-free
    – Dale
    Nov 30, 2016 at 20:00
  • I restarted my computer and entered bios: BIOS Version: F.0A, Bios Vendor: Insyde, at the top it said, "Insyde H2O Setup Utility Rev 3.7
    – Dale
    Nov 30, 2016 at 20:11
  • I don't know how this is, but that image isn't what is displayed in my BIOS. There are only two options in the security tab and both are password related. The computer was originally Windows 7, so it may not have secure boot.
    – Dale
    Nov 30, 2016 at 20:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .