11

I own a Debian laptop with KDE. Occasionally, after I close and re-open my laptop, text starts to appear like this: GIMP

The text does not go back to normal until I restart my computer. This problem only affects these characters: cgnpqtEFM13589@|: and it only seems to affect one font. I have also noticed that bold letters are affected differently:

Firefox

Also, all of the weird o's in the picture above are exactly the same (maybe my computer is somehow switching to another font or something?). This problem has not affected my desktop (which also has Debian and KDE). Is there any way I can solve this problem?

cat /etc/default/locale

Produces

#  File generated by update-locale
LANG="en_CA.UTF-8"
LANGUAGE="en_CA:en"    

Also, lspci produces:

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:03.0 Communication controller: Intel Corporation Mobile 4 Series Chipset MEI Controller (rev 07)
00:03.3 Serial controller: Intel Corporation Mobile 4 Series Chipset AMT SOL Redirection (rev 07)
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode] (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV620/M82 [Mobility Radeon HD 3450/3470]
03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection
15:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ba)
15:00.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 04)

The font is DejaVu Sans, however it doesn't seem to affect all DejaVu Sans text (e.g. it doesn't affect the Firefox URL bar).

  • 2
    broken videocard driver – Ipor Sircer Nov 30 '16 at 0:56
  • 2
    Probably broken font rendering for this particular font. If you can identify the font and the library rendering it, file a bug. – dirkt Nov 30 '16 at 7:45
  • Please add the output of cat /etc/default/locale – GAD3R Nov 30 '16 at 13:38
  • Try changing the font size. It worked for my ubuntu install. I had to experiment with a lot of sizes, the fonts appeared broken on all but some particular sizes. – saga Dec 18 '16 at 2:24
  • I has that happen to me in 1998 with a much older version of KDE and X11, I think the problem was font cache corruption due to bad video RAM refresh, I don't recall what I did to mitigate it. – Jasen Dec 25 '16 at 11:53
1

Looks like a video card issue to me. If you use a closed source driver, try the open source one (and vice versa). Try upgrading Xorg, try toggling the option for 3D/hardware acceleration in KDE. Trying with Xfce4 and another font might also be worth a shot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.