1

I am working on Satellite 6.2 and I have moved like 200+GB of custom repositories to the local machine. These sub directories and files are under /home/import/XX directory, because this dir is on a different disk.

Anyways, so under the localhost/pub I created a folder called imports and from there, I created a sym link pointing to /home/imports.

The issue is on the web side, I go to http://localhost/pub/import and I can see the XX directory (one pointing to the home dir) but when I click on it I get

"Forbidden You don't have permission to access /pub/imports/XX/ on this server."

I checked the httpd.conf and made sure the FollowSymLinks was there:

AccessFileName .htaccess
<FilesMatch "^\.ht">
    Options FollowSymLinks
    Require all denied
</FilesMatch>

<Directory />
  Options FollowSymLinks
  AllowOverride None
</Directory>

I also checked the permissions and the symbolic link looks like this

imports]# ll
total 0
lrwxrwxrwx. 1 root root 54 Nov 29 14:01 XX -> /home/imports/XX

Further, I checked the permissions on the /home/imports/

ll -r /home/imports/XX/
total 0
drwxr-xr-x. 3 root root 20 Nov 29 11:35 XX

Is there anything obvious am I might be missing? I've spent a few hours and I cannot find a possible answer why I cannot access it.

3
  • What happens if you su as web user (usually apache) and then try accessing the files?
    – Abey
    Nov 29, 2016 at 21:13
  • I can't, the web (apache) user does not have a login shell and would not "This account is currently not available" Nov 30, 2016 at 12:09
  • @user3311890 In that case you can use sudo -u apache ls /path/to/file You can also use touch or test or probably a half dozen other commands.
    – Centimane
    Nov 30, 2016 at 14:41

1 Answer 1

-1

If anybody hits the same road, even if Apache has configured the FollowSymLinks, there are other security permissions in place. This is due to a SELinux. I had to modify the /etc/sysconfig/selinux and chnage this line SELINUX=permissive

After that, I rebooted the server and was able to access via web browser the files normally.

1
  • That only "works" because you turned off SELinux. You should have just changed the SELinux context of the files. Nov 30, 2016 at 14:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .