2

I have recently installed Debian Jessie, now I want the Grub menu to show two options: 1) normal GUI and 2) terminal/text only.

I've found many tutorials showing how to add a different Operating System to Grub, but this is not my case. I only need text mode to do some heavy processing in R, so I need to free as much memory as possible.

0

2 Answers 2

1

Add a Grub entry with the kernel parameter systemd.unit=multi-user.target. This is parsed by systemd, which boots to multi-user instead of graphical.target, which is the normal default.

4
  • Thank you, but I want to have both options in the Grub menu, not to switch configuration files every time I need the other boot.
    – Rodrigo
    Nov 29, 2016 at 22:41
  • That was my point exactly. Add a second boot entry that is identical to the one you have now, except that it has the extra kernel parameter (the labels should be different too, of course.) Then you choose between these entries at boot time. Nov 30, 2016 at 5:37
  • Thanks again. Only that "identical" is kind of problematic. In /etc/grub.d/ I have 10_linux > 12 KB and 40_custom = 214 bytes. Not sure at all what to copy.
    – Rodrigo
    Nov 30, 2016 at 17:43
  • From Grub2/CustomMenus: "The surest way to build a custom menu is to copy one or more working menuentries from the grub.cfg file". Nov 30, 2016 at 19:04
0

Then simply don't start your display manager, e.g. gdm.

systemctl disable gdm
10
  • Thank you, but I want to have both options in the Grub menu, not to switch configuration files every time I need the other boot.
    – Rodrigo
    Nov 29, 2016 at 22:41
  • wtf? you can anytime start the graphic interface with systemctl start gdm. there is no need for reboot. Nov 30, 2016 at 0:08
  • Good to know. But other people (not so tech-savvy) use my computer, so I want to make things easier to them. Also, I'm using the GUI most of the time, so it would ideally be the default menu option.
    – Rodrigo
    Nov 30, 2016 at 4:21
  • Then make gdm the default, and you can anytime stop it with systemctl stop gdm. You are smart, you can remember this easy command. (gdm eats about 10-20mb ram... i wonder how much memory is in that computer, when +20mb ram does matter) Nov 30, 2016 at 11:08
  • 1
    Argh#2... Why have you login at gdm? I spoke about gdm, not the whole desktop. When you are on the login screen, dont login, press ctrl+alt+f1, and use the terminal. (calendar and other resource wasting thing are started after you logon in gdm, so dont logon in gdm) Nov 30, 2016 at 17:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .