2

I need to install mysql-server-5.7, but the highest version in debian repo is 5.6. I've tried to find the way to install 5.7. Can't remember all tried, but I didn't manage to to that. Instead of it I have now new issue. When I try to delete mysql-5.6, I get this:

sudo apt-get remove mysql-server-5.6
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libmysqlclient-dev : Depends: libmysqlclient18 (= 5.6.30-1) but 5.6.34-1debian8 is to be installed
 libmysqlclient18 : Depends: mysql-common (= 5.6.34-1debian8)
 libpam-systemd : Depends: systemd (= 232-6)
 mysql-server : Depends: mysql-server-5.6
 udev : Depends: libudev1 (= 232-3) but 232-6 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

And even purge doesn't work..

One more detail - I can't apply system updates. When I try to run update with Gnome Package Updater, I get "Error while installing package: trying to overwrite '/usr/share/man/man1/mysql_config_editor.1.gz', which is also in package mysql-client-5.6 5.6.30-1"

sudo apt-get -f install doesn't work

sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  firebird2.5-common firebird2.5-common-doc firebird2.5-server-common firebird3.0-common firebird3.0-common-doc gstreamer1.0-plugins-base:i386 i965-va-driver:i386 imagemagick-common libappindicator3-1 libasound2:i386 libasound2-plugins:i386 libasyncns0:i386 libaudio2:i386 libavahi-client3:i386
  libavahi-common-data:i386 libavahi-common3:i386 libavcodec57:i386 libavresample3:i386 libavutil55:i386 libboost-atomic1.61.0 libboost-chrono1.61.0 libboost-thread1.61.0 libcairo2:i386 libcap2:i386 libcdparanoia0:i386 libcrystalhd3:i386 libcups2:i386 libcurl3 libdbus-1-3:i386 libdbusmenu-gtk3-4 libfbclient2
  libfbembed2.5 libflac8:i386 libfontconfig1:i386 libfreerdp-client1.1 libfreetype6:i386 libglib2.0-0:i386 libgmp10:i386 libgnutls30:i386 libgomp1:i386 libgsm1:i386 libgssapi-krb5-2:i386 libgstreamer-plugins-base1.0-0:i386 libgstreamer1.0-0:i386 libhogweed4:i386 libice6:i386 libidn11:i386 libindicator3-7
  libjack-jackd2-0:i386 libjbig0:i386 libjpeg62-turbo:i386 libjson-c3:i386 libk5crypto3:i386 libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386 liblcms2-2:i386 liblz4-1:i386 libmagick++-6.q16-5v5 libmng1:i386 libmp3lame0:i386 libnettle6:i386 libnuma1:i386 libogg0:i386 libopenjp2-7:i386 libopus0:i386
  liborc-0.4-0:i386 libosinfo-db libp11-kit0:i386 libpixman-1-0:i386 libpng16-16:i386 libpulse0:i386 libqt4-dbus:i386 libqt4-network:i386 libqt4-opengl:i386 libqt4-xml:i386 libqt4-xmlpatterns:i386 libqtcore4:i386 libqtdbus4:i386 libqtgui4:i386 libqtwebkit4:i386 libsamplerate0:i386 libschroedinger-1.0-0:i386
  libshine3:i386 libsm6:i386 libsnappy1v5:i386 libsndfile1:i386 libsoxr0:i386 libspeex1:i386 libspeexdsp1:i386 libsqlite3-0:i386 libswresample2:i386 libsystemd0:i386 libtasn1-6:i386 libtheora0:i386 libtiff5:i386 libtommath1 libtwolame0:i386 libva-drm1:i386 libva-x11-1:i386 libva1:i386 libvdpau-va-gl1:i386
  libvdpau1:i386 libvisual-0.4-0:i386 libvncclient1 libvorbis0a:i386 libvorbisenc2:i386 libvpx4:i386 libvte-common libvte9 libwavpack1:i386 libwebp6:i386 libwebpmux2:i386 libwrap0:i386 libx264-148:i386 libx265-95:i386 libxcb-composite0 libxcb-randr0:i386 libxcb-render0:i386 libxcb-shape0:i386 libxcb-shm0:i386
  libxcb-xfixes0:i386 libxi6:i386 libxnvctrl0 libxrender1:i386 libxt6:i386 libxtst6:i386 libxv1:i386 libxvidcore4:i386 libzvbi0:i386 linux-image-4.6.0-1-amd64 mesa-va-drivers:i386 mesa-vdpau-drivers:i386 node-sigmund psensor-common python-gobject qt-at-spi:i386 va-driver-all:i386 vdpau-driver-all:i386 vlc-nox
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libmysqlclient-dev libsystemd0 libsystemd0:i386 mysql-common:i386 systemd udev
Suggested packages:
  systemd-ui systemd-container
The following packages will be REMOVED:
  mysql-common
The following NEW packages will be installed:
  mysql-common:i386
The following packages will be upgraded:
  libmysqlclient-dev libsystemd0 libsystemd0:i386 systemd udev
5 upgraded, 1 newly installed, 1 to remove and 144 not upgraded.
5 not fully installed or removed.
Need to get 5,442 kB of archives.
After this operation, 6,047 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://repo.mysql.com/apt/debian jessie/mysql-5.6 amd64 libmysqlclient-dev amd64 5.6.34-1debian8 [1,124 kB]
Get:2 http://debian.org.ua/debian stretch/main amd64 udev amd64 232-6 [1,100 kB]
Get:3 http://repo.mysql.com/apt/debian jessie/mysql-5.6 i386 mysql-common i386 5.6.34-1debian8 [203 kB]
Get:4 http://debian.org.ua/debian stretch/main amd64 systemd amd64 232-6 [2,452 kB]
Get:5 http://debian.org.ua/debian stretch/main i386 libsystemd0 i386 232-6 [290 kB]
Get:6 http://debian.org.ua/debian stretch/main amd64 libsystemd0 amd64 232-6 [273 kB]
Fetched 5,442 kB in 2s (2,341 kB/s)  
Reading changelogs... Done
(Reading database ... 170515 files and directories currently installed.)
Preparing to unpack .../0-libmysqlclient-dev_5.6.34-1debian8_amd64.deb ...
Unpacking libmysqlclient-dev (5.6.34-1debian8) over (5.6.30-1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-mNfUdL/0-libmysqlclient-dev_5.6.34-1debian8_amd64.deb (--unpack):
 trying to overwrite '/usr/share/man/man1/mysql_config_editor.1.gz', which is also in package mysql-client-5.6 5.6.30-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Selecting previously unselected package mysql-common:i386.
Preparing to unpack .../1-mysql-common_5.6.34-1debian8_i386.deb ...
Unpacking mysql-common:i386 (5.6.34-1debian8) over (5.8+1.0.1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-mNfUdL/1-mysql-common_5.6.34-1debian8_i386.deb (--unpack):
 trying to overwrite '/usr/share/mysql/polish/errmsg.sys', which is also in package mysql-server-core-5.6 5.6.30-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /tmp/apt-dpkg-install-mNfUdL/0-libmysqlclient-dev_5.6.34-1debian8_amd64.deb
 /tmp/apt-dpkg-install-mNfUdL/1-mysql-common_5.6.34-1debian8_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

What's going on here and how can it be fixed? :)

  • It's better and more easy way to use sid repository when you already using testing (mysql-server-5.7=5.7.16-1). Fix with apt-get -f install as the error message said. – Ipor Sircer Nov 29 '16 at 12:03
  • @IporSircer apt-get -f install doesn't work. Added output to description. I believe I I screwed up with dependencies somehow – Ivan Leonov Nov 29 '16 at 12:11
1
rm /var/lib/dpkg/info/mysql-server-core-5.6.list /var/lib/dpkg/info/mysql-server-client-5.6.list
apt-get -f install

Next time avoid from manually installing not debian released packages on Debian.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.