2

I'm trying to get spacewalk to work with our Centos 7 servers and am encountering the below error when i run 'yum update'. i have set the server up to use the spacewalk server and spacewalk can successfully see the status of the system including what packages are installed.

failed to retrieve repodata/repomd.xml from centos7 error was [Errno 14] curl#51 - "Unable to communicate securely with peer: >requested domain name does not match the server's certificate."

the spacewalk server is using https but that shouldn't be an issue as all the appropriate certificates have been installed. (i think)

has anyone encountered this error before?

i've tried updating nss completely as i read an outdated nss package can cause issues, but this did not resolve the issue.

any suggestions would be great.

  • run from command like "curl your.spacewalk" and see if curl will like the https certificate or not. If it does not accept that certificate then rhn-client-tools will not accept it neither. – msuchy Dec 1 '16 at 10:12
0

Actually no need to create new certificate , just by changing server url in spacewalk client as same as your server certicate CN in /etc/sysconfig/rhn/up2date

0

In the end, it was a relatively simple thing that stopped yum from working.

  1. Recreated the SSL certs on the spacewalk server with fqdn spacewalk.mydomain.com

  2. rebooted server

  3. re-registered client with the hostname of spacewalk server... rather than the alias. e.g serverhostname.mydomain.com

for some reason, even if I generated the certs on the spacewalk server with my alias (spacewalk.mydomain.com) it would only accept the cert on the client ends if the server name was specified.

However, it may have simply been the fact that I rebooted the server.

ahh, the simple things...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.