2
   ./linux rootfstype=hostfs mem=64M rw init=/bin/bash 
    Core dump limits :
        soft - NONE
        hard - NONE
    Checking that ptrace can change system call numbers...OK
    Checking syscall emulation patch for ptrace...OK
    Checking advanced syscall emulation patch for ptrace...OK
    Checking environment variables for a tempdir...none found
    Checking if /dev/shm is on tmpfs...OK
    Checking PROT_EXEC mmap in /dev/shm...OK
    Adding 10289152 bytes to physical memory to account for exec-shield gap
    Aborted (core dumped)

I'm using

linux-4.4.35

which I compiled using

gcc --version
gcc (Ubuntu 5.4.0-6ubuntu1~16.04.4) 5.4.0 20160609

It's possible I should be using a package, but it's not available in ubuntu 16.04

I'm following the instructions from here, verbatim. I used a newer linux kernel, since 3.10 doesn't compile with GCC-5

https://techoverflow.net/blog/2013/07/09/user-mode-linux-for-beginners-part-1-setup-and-first-vm/

2
  • I was getting this same error. I was able to run one of the precompiled binaries from here: uml.devloop.org.uk/kernels.html
    – bcattle
    Aug 2, 2017 at 22:06
  • Since the abort came very early, and the amount of memory you are allocating to UML is very small (64M) it looks like you ran out of memory early in the boot process. Have you tried giving it more memory? Try 128M and see if the boot progresses further. If so, you're on to something. Gradually add memory until the boot process completes, or something else breaks.
    – Hugh Buntu
    Sep 9, 2021 at 4:04

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.