3

I am running Debian 8.2 Jessie with an AMD Radeon RX 460. MATE is my desktop environment. I use two monitors.

Anything on Monitor 1 is displayed on Monitor 2. I want instead for Monitor 2 to be like an extension of Monitor 1, as you would see in many monitor setups.

Is this possible with Debian 8.2 and my RX 460?

Edit

Output of running xrandr -q in MATE Terminal:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1920 x 1080, maximum 1920 x 1080
default connected 1920x1080+0+0 0mm x 0mm
   1920x1080      0.00* 
   1280x1024      0.00  
   1024x768       0.00  
   800x600        0.00  
   640x480        0.00 

Output of uname -a:

Linux desktop 3.16.0-4-amd64 #1 SMP Debian 3.16.36-1+deb8u2 (2016-10-19) x86_64 GNU/Linux
  • Look into ARandR. might help – jc__ Nov 28 '16 at 19:49
  • @jc__ Hm, the GUI does not seem to detect the second monitor... – Username Nov 28 '16 at 20:01
  • Since you are running Debian, there is a good chance you are running Gnome. If so the simplest thing to try is running gnome-control-center display and see if that sees your two displays. – icarus Nov 29 '16 at 2:00
  • @icarus That package does not show up in the list of packages I can install. I'm using MATE desktop environment rather than GNOME. – Username Nov 29 '16 at 5:34
  • OK, I am out of my depth, so this is just generic advice until someone who can help comes along. Can you run xrandr -q? If so can you add the output to the question? What we are aiming for are the names of the outputs of the RX 460, and then we can try telling it to drive them separately. Probably Mate will have a pretty gui to drive this, but let me try and help via a cli. – icarus Nov 29 '16 at 6:22
0

I had a similar issue and it appeared (bug report) it was due to the fact that the proprietary binary-only firmware was not installed on my system.

That firmware ships with firmware-linux-nonfree. I installed that package (RMS won't be proud anymore...) and now it works.

See Debian wiki about radeon proprietary firmware.

  • Installing that package did nothing for me – Username Jan 11 '17 at 0:29
  • Sorry to hear that. Still relevant to you in the bug report : 'Output name "default" means you're not using the radeon driver but some kind of generic fallback driver.' You may want to check your Xorg log and dmesg output to figure out what is wrong. Do you still get the same xrandr output? – Jérôme Jan 11 '17 at 8:31
  • I'd like to keep this answer here anyway as it may help someone with the same symptoms: it would have saved myself some time and I wouldn't have wasted the developers time with a wrong bug report. – Jérôme Jan 11 '17 at 8:32
  • I get the same xrandr output – Username Jan 17 '17 at 20:22
  • Weird. It would mean you have the firmware installed but not loaded? From the answer I had on the bugtracker, I suggest you edit your question with Xorg log and dmesg output. – Jérôme Jan 17 '17 at 23:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.