0

Today I installed 2 Ubuntu versions. 1st I installed Ubuntu 16.04 LTS and then Ubuntu 16.10. But after booting into the later system, i.e. Ubuntu 16.10, it is throwing error "Sorry, Ubuntu 16.10 has experienced an internal error". Is this a known issue with this Ubuntu version and so other persons who installed on their machines are also getting the same error message? Please see a part of the error message in the screen shot below.

error message Ubuntu 16.10

Also if you see the above image, there is a button in the right bottom where it is written "Continue". With an intent to send this error report to fix this problem, I click on continue but I am not getting any confirmation message that my error report is successfully sent! So, is it O.K. or any issue in sending the report to the company?

EDIT

This edit is w.r.t. the method posted by "GAD3R" in the comment to this Q. I ran

 sudo dpkg --add-architecture i386
 sudo apt-get update 
 sudo apt-get upgrade 
 sudo apt-get dist-upgrade 
 reboot

All the commands ran successfully but when I ran the 1st one sudo dpkg --add-architecture i386, it didn't give any output as such. Simply the prompt returned back. I hope it ran as expected! How to confirm that it ran successfully?

Then the very next day, I booted my system again and immediately the same error popped up on my screen as earlier?

The screen shot of the error is shown below:

enter image description here

  • Run sudo dpkg --add-architecture i386 then update , upgrade and dist-upgrade reboot – GAD3R Nov 27 '16 at 21:27
  • 1
    @GAD3R today I've done what you suggested. I will check for a few days that the error message doesn't pop up again. Because earlier every now and then, the error was popping up. Now, lets see! You can even post this as answer explaining the reason why the error message was coming and what solution you suggested and why. This will be better in following up this question and accordingly I will accept this as answer that would benefit other viewers. – Ravi Dec 18 '16 at 15:14
1

The Apport service is enabled by default on Ubuntu 16.10 to generates the crash reports. The error will be successfully reported even if you have not received a confirmation . You can check all the error report as follow :

Go to System Settings choose the security & Privacy > Diagnostics. Click Show Previous Reports you will be redericted to a ubuntu webpage witch contains all the report bugs uploaded from your system.

To avoid getting the annoying popups you can disable the apport service.

Check the status:

sudo systemctl status apport

Edit the /etc/default/apport file:

sudo nano /etc/default/apport

Change the value enabled=1 to enabled=0

Then disable/stop the service:

sudo systemctl stop apport.service
sudo systemctl disable apport.service

Or you can remove it completely:

sudo apt-get purge apport

Disabling the service is not commanded , because a report bug will help the developers to quickly solve the existing problem on the testing distro .

  • Unfortunately, the method you mentioned in the comment to my Q didn't work. The next time I booted my system, the same error message popped-up! Please see my edit in the Q for the error message. – Ravi Dec 20 '16 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.