28

I just installed Arch Linux today. I am trying to install elinks using

pacman -S elinks

And I get a long, long list of:

error: failed retrieving file 'elinks-0.13-17-i686.pkg.tar.xz' from some.mirror : Could not resolve host: some.mirror

The same happens if I try to install any other software. The only thing I could think of based on what I read is a connection problem, but I'm on the same connection that I used to install the OS, and that was just a few minutes ago.

2
  • The live medium will connect automatically; once you have installed Arch, you have to set up networking yourself...
    – jasonwryan
    Nov 27, 2016 at 1:58
  • @jasonwryan Thanks! Like I said, I'm new to this...
    – The Ledge
    Nov 27, 2016 at 7:51

4 Answers 4

43

Although this has been answered, I encountered the same issue. I resolved it by updating my databases while installing. For instance:

sudo pacman -Syu elinks
1
  • Adding the yu after the S seemed to make the difference. I'd already tried --disable-download-timeout which didn't work on it's own so I had -Syu and --disable-download-timeout and it then worked.
    – NeilG
    Aug 13, 2023 at 23:05
9

I found an answer, thanks to jasonwryan's comment.

I tried lots of things to get my ethernet connection to work and it still didn't work till I researched the netctl command (https://wiki.archlinux.org/index.php/netctl, man netctl).

ls /etc/netctl revealed that there were no profiles in my /etc/netctl folder, so I ran

cp /etc/netctl/examples/ethernet-dhcp /etc/netctl
netctl start ethernet-dhcp

Before that, I had run (from https://bbs.archlinux.org/viewtopic.php?id=151483)

systemctl enable [email protected]
systemctl start [email protected]

And voila, the internet was working. Not sure which of the commands was responsible, but now it works.

8

Update your pacman mirrors:

sudo pacman-mirrors -g
4
  • This helped me, I think my mirrors got borked. Didn't realize this command existed! (Using manjaro over here)
    – SeedyROM
    Mar 10, 2021 at 15:26
  • 1
    Glad to help :)
    – tristobal
    Mar 10, 2021 at 20:13
  • 1
    Had to create a new account just so I can upvote :) Thank you, fixed it for me with a single command.
    – JKleinne
    Jun 19, 2021 at 23:55
  • 1
    sudo: pacman-mirrors: command not found but adding the disable timout and Syu solved: sudo pacman -Syu --asdeps --disable-download-timeout graphicsmagick
    – NeilG
    Aug 13, 2023 at 23:02
0

You can also download the package(pkg.tar.zst file) manually and use the command

sudo pacman -U package_name.pkg.tar.zst

I used this method as sudo pacman -Syu command wanted to install few extra packages of total size ~200mb, and all i have was a 8kb/s net connection

1
  • 1
    8kb/s in 2020 in kerala? Unbelievable
    – Prasanna
    Sep 10, 2022 at 11:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .