1

I've installed Debian on a partition on my Macbook Pro (15-inch, Mid 2012) (MacBookPro9,1). I'm having some strange issues with my keyboard/trackpad.

When I boot normally from GRUB, I get a black screen with a frozen "_" cursor in the upper left corner. This happens when I have plugged in an external keyboard as well.

If I boot with acpi=off , I get to the login screen, but no response from keyboard or trackpad. If I plug in an external keyboard, however, it does work - but the built-in keyboard and trackpad remain non-responsive.

If I boot with nolacpi , if no external keyboard is plugged in I get the same frozen black screen as above. However, if I have an external keyboard plugged in, I get to the login screen and both the external keyboard AND the built-in keyboard/trackpad work! If I unplug the external keyboard, the built-in keyboard/trackpad continue to work. However, if I reboot with the external keyboard unplugged, I get the same black screen.

Anybody ever run into this behavior before? I would rather not have to plug in an external keyboard every time I want to reboot :)

Update: the frozen black screen now seems to happen at random, regardless of acpi on or off, and regardless of external keyboard plugged in or not!

Log that cycles every ~2 minutes during frozen black screen:

    INFO: task Xorg:957 blocked for more than 120 seconds.

    Not tainted 3.16.0-4-amd64 #1

    "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.

    Xorg            D ffff880262f06e38     0   957    827 0x00400000

    ffff880262f069e0 0000000000000082 0000000000012f40 ffff88008c5bbfd8

    0000000000012f40 ffff880262f069e0 ffff880262f069e0 ffff880262f069e0

    0000000000000000 ffff880265c31dc0 0000000000000286 ffff880265c0b000

    Call Trace:

    [<ffffffff8139f3a6>] ? vga_get+0x126/0x1e0

    [<ffffffff810982e0>] ? wake_up_state+0x10/0x10

    [<ffffffff8139f6e2>] ? vga_arb_write+0xb2/0x640

    [<ffffffff812368bd>] ? security_file_permission+0x1d/0xa0

    [<ffffffff811aa872>] ? vfs_write+0xb2/0x1f0

    [<ffffffff811aa73d>] ? vfs_read+0xed/0x170

    [<ffffffff811ab3b2>] ? SyS_write+0x42/0xa0

    [<ffffffff8151858d>] ? system_call_fast_compare_end+0x10/0x15
  • share your acpi dump, DSDT, SSDT tables, I'm sure it can be resolved but debugging firmware is not fun. also get rid of "quiet" and "splash" from the boot options, they hide the truth. – mikejonesey Nov 26 '16 at 18:51
  • When I remove "quiet", a lot of text flashes on the screen and then it goes directly to the black screen, but it doesn't tell me at which point it's freezing. I've put the tables here. Thanks! – BubblesInsideMe Nov 28 '16 at 15:30
  • sorry to be a pain, can you boot with acpi=off, the grab the /var/log/messages (using external keyboard for now...), make sure to boot and crash before getting /var/log/messages. (perhaps there will be a clue as to which module is loaded before black screen). the dsdt looks clean enough, can you try booting with: "acpi_no_static_ssdt", this will work much like the acpi=off, however it will allow the dsdt to load. The dsdt has the core functionality, the ssdt have additional functionality like one file for vga, one for tpm so on – mikejonesey Nov 28 '16 at 20:49
  • This is getting stranger... it no longer seems to be a reliable pattern when it freezes on the black screen or not. Even with the external keyboard and acpi=off, it froze. Then I tried acpi_no_static_ssdt, and it worked (without the external keyboard). But I repeated it and it froze again. Now I just tried a normal boot and everything worked! It really seems to be random. – BubblesInsideMe Nov 28 '16 at 21:33
  • These seem to be the last lines before freezing: Nov 28 22:09:27 ms1 kernel: [ 8.598523] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready Nov 28 22:09:42 ms1 kernel: [ 23.877662] wlan0: deauthenticating from 1c:c6:3c:8b:13:c4 by local choice (Reason: 3=DEAUTH_LEAVING) – BubblesInsideMe Nov 28 '16 at 21:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.