0

My MacBook Pro has two internal hard drives, and they're now laid out like this:

  • SSD
    • Mac HD
    • Bootcamp
  • SATA
    • Storage (for Mac)
    • grub/bios/boot
    • swap
    • linux mint

During the Mint installer, when asked where to install GRUB, I selected /dev/sdb (the SATA drive). rEFInd correctly sees 3 OS'es, but if I choose either Windows (something like /dev/sda2) or Mint (/dev/sdb4 ?) they both boot Windows.

Not sure what I did wrong, or how to fix it. Any advice would be helpful.

Thanks!

Edit - when it boots windows (after selecting Linux in rEFInd) it doesn't even show grub. So I'm imagining I installed grub wrong. Hrm.

0

I'm still not sure what the cause was, but after many reinstalls, I eventually noticed that when booting from the Mint installer DVD, rEFInd was offering a few different boot options from the DVD. One of them was an EFI boot. Selecting this option worked.

I instructed the installer to install Mint to /dev/sdb4, and GRUB to the same partition. Not sure what ended up happening, as I still have no visibility of GRUB. Now when I boot my MacBook, it boots directly into Mint. If I hold Alt (Option) down at boot, the OS X boot-selector allows me to select between OS X, Windows, and Windows (which is actually Mint).

Up and running -- thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.