2

I recently did an apt-get dist-upgrade on Debian Sid and one of the things it did was uninstall X.org, which is fine, I don't need X.org but I ran into a problem. gdm3 wouldn't start so I went into recovery mode and disabled auto-login, rebooted and I was greeted with the gdm3 login screen where I selected Gnome on Wayland as my session and then logged in. That worked fine but if I re-enable auto-login it tries to use X11 and fails to start. How can I make it so that under auto-login gdm will use the wayland session?

0

This is a bug in GNOME prior to 3.25.3.

Your question is old, chances are you have upgraded to Stretch. If this is the case you could check Debian Stretch: How do I make Wayland the default?.

Otherwise you could patch the source and rebuild. Or as a workaround you could setup a timed login with a 1 second delay.

  • Thanks for the answer. I'll go ahead and mark it as the answer although I have long since fixed this problem. – Scoopta Aug 22 '17 at 17:05
  • Out of curiosity how did you resolve the problem? – marcv81 Aug 23 '17 at 2:22
  • 1
    I disabled auto-login until the X.org dependencies were fixed and then switch back to X.org until the issue was fixed properly. The current release of Debian sid defaults to wayland and will auto-login to whatever session you last used so I can easily just switch by logging out and back in and it'll remember it for next time. – Scoopta Aug 23 '17 at 3:21
  • Thanks for your reply! I didn't expect this to work in Sid because of a comment in the Debian bug tracker. However I had a look at the source in Sid and the patch is indeed there. – marcv81 Aug 23 '17 at 3:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.