As I don't use GUI for archive extraction much, I don't know since when this error I am getting:

An error occurred while loading the archive.

This error I get while trying to open an ordinary Zip and / or 7z archives, but I care only about Zip in this question.

I am able to open tar.bz2 and tar.gz files, though.

As a side note: This is particularly annoying as I started using Thunderbird for mail and so I intend to open all attachments in GUI.

OS and DE: Linux Mint 18.1 Cinnamon 64-bit.

Version of Archive manager for GNOME:

/usr/bin/file-roller --version
file-roller 3.16.5, Copyright © 2001-2012 Free Software Foundation, Inc.


A file downloaded from GitHub from this page as Zip: TrueColour.md

For convenience renamed to truecolor.zip.

file truecolor.zip

says it is an ordinary Zip archive:

truecolor.zip: Zip archive data, at least v1.0 to extract
file-roller truecolor.zip

run from terminal says the above error message with no output to the terminal.

Sure though, I am able to decompress it with:

unzip truecolor.zip

with output:

Archive:  truecolor.zip
   creating: 8346728-f8e6e08a0f0d3ad09e599a4f17edc010d38e4ec8/
  inflating: 8346728-f8e6e08a0f0d3ad09e599a4f17edc010d38e4ec8/TrueColour.md  


I have managed to get some, possibly useful, debug info using:

strace -t -f file-roller truecolor.zip 2> fileroller-open-zip-strace

As it is rather lengthy, it won't fit into Pastebin, so I have compressed it, SHA-256 hash follows:


You may download it from my hosting:


The above file has been deleted.

If someone knows what to look for in the strace's output, I am sure he / she would find the relevant part, but I sadly don't know what to look for.


Latest available version on GitHub, compiled:

./file-roller --version
file-roller 3.22.2, Copyright © 2001-2012 Free Software Foundation, Inc.

run from terminal:

./file-roller ~/Downloads/truecolor.zip

shows the very same error message:

An error occurred while loading the archive.

3 Answers 3


I had to self-compile the p7zip package, now everything works as usual.

I tried purging p7zip-full and installing it back, but that didn't do anything, I still wonder why. Nevermind, solution was to build the package myself, I should have done that long time ago.


I had this same error on a new install of Linux Mint 18.1 Cinnamon trying to open files I'd created with an older version of Mint (14?). I discovered that I only had the "light" version installed with the distro and had to install "p7zip-full" to get encryption support. Did that and the files open as they should now.


I had the same problem as you.

Finally, I've found an old 7z shell script in bin directory, that claimed to launch the 7z executable from an incorrect path.

After removing this wrong script, the problem was solved.

So, check your shell aliases and personal shell scripts, in order to discover any error concerning programs used by file-roller application to manage the archive file types.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .