3

I created the following .desktop file under Fedora 24 using GNOME 3.

[Desktop Entry]
Encoding=UTF-8
Name=Jabref
Exec=java -jar /home/zoltan/Bureau/Programs/JabRef-3.7-dev--snapshot--2016-11-08--master--fffad83.jar
Icon=/home/zoltan/Bureau/Programs/Icons/Jabref
Type=Application
Categories=Development

When I opened it from the desktop, it launched the application, however when I copied it to /usr/share/applications, the system couldn't recognise it and so I cannot launch it quickly. What can be the problem?

  • Sorry for my reckless answer. I don't think I can help. – Tomasz Nov 23 '16 at 15:32
1

Have a look here: https://developer.gnome.org/integration-guide/stable/desktop-files.html.en

It could be possible gnome to be quite sensitive in the "Categories" section. You might need to modify like

Categories=GTK;GNOME;Development; 

PS: By the way i just noticed that your "categories" entry is not "closed" with ";" character.

Also, i'm not sure if Development category is present under gnome. You can apply another category (i.e Settings;) to see if it works.

Last chance you could try to modify an existing .desktop file....

  • Thanks George, gedit can recognise .desktop files and highlighted the Development category in red. It recognised GTK and GNOME too, so I wrote Categories=GTK;GNOME; (at this time I ended with a semicolon). But still the same. Even after modifying the existing .desktop files. – Zoltán Csáti Nov 23 '16 at 16:14
  • Very strange...Maybe you could try alacarte for testing... – George Vasiliou Nov 23 '16 at 16:41
  • I see all the files in that dir have root ownership. Maybe that's the thing? – Tomasz Nov 23 '16 at 16:56
  • Yes, I also tried alacarte. However, that was buggy on Fedora 24: when I tried to set the path, the OK button remained inactive. I read somewhere that alacarte contains bugs on the latest GNOME 3. – Zoltán Csáti Nov 23 '16 at 16:56
  • @tomas Yes, I edited the jabref.desktop with sudo. And I also tried sudo alacarte, but that opened alacarte as a blank app. – Zoltán Csáti Nov 23 '16 at 16:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.