1

I have an arm-based board (nanopi m1, something like raspberry), and I tried to update the date and time! I used every methods I saw in the web but it didn't work!(Actualy my default date was 1970 in my board but I changed the timesyncd.conf and ntp.conf and set the servers to 0-4.ir.pool.ntp.org iburst and my date changed to 2014 !)

How can I fix this problem?

This is content of my "ntp.conf" file:

# /etc/ntp.conf, configuration for ntpd; see ntp.conf(5) for help

driftfile /var/lib/ntp/ntp.drift


# Enable this if you want statistics to be logged.
#statsdir /var/log/ntpstats/

statistics loopstats peerstats clockstats
filegen loopstats file loopstats type day enable
filegen peerstats file peerstats type day enable
filegen clockstats file clockstats type day enable


# You do need to talk to an NTP server or two (or three).
#server ntp.your-provider.example

# pool.ntp.org maps to about 1000 low-stratum NTP servers.  Your server will
# pick a different set every time it starts up.  Please consider joining the
# pool: <http://www.pool.ntp.org/join.html>
#server 0.debian.pool.ntp.org iburst
#server 1.debian.pool.ntp.org iburst
#server 2.debian.pool.ntp.org iburst
#server 3.debian.pool.ntp.org iburst
server 1.ir.pool.ntp.org
server 1.asia.pool.ntp.org
server 0.asia.pool.ntp.org

# Access control configuration; see /usr/share/doc/ntp-doc/html/accopt.html for
# details.  The web page <http://support.ntp.org/bin/view/Support/AccessRestrictions>
# might also be helpful.
#
# Note that "restrict" applies to both servers and clients, so a configuration
# that might be intended to block requests from certain clients could also end
# up blocking replies from your own upstream servers.

# By default, exchange time with everybody, but don't allow configuration.
restrict -4 default kod notrap nomodify nopeer noquery
restrict -6 default kod notrap nomodify nopeer noquery

# Local users may interrogate the ntp server more closely.
restrict 127.0.0.1
restrict ::1

# Clients from this (example!) subnet have unlimited access, but only if
# cryptographically authenticated.
#restrict 192.168.123.0 mask 255.255.255.0 notrust


# If you want to provide time to your local subnet, change the next line.
# (Again, the address is an example only.)
#broadcast 192.168.123.255

# If you want to listen to time broadcasts on your local subnet, de-comment the
# next lines.  Please do this only if you trust everybody on the network!
#disable auth
#broadcastclient

Also I get this warnings after running this command:

systemctl enable fake-hwclock.service

Synchronizing state for fake-hwclock.service with sysvinit using update-rc.d...
Executing /usr/sbin/update-rc.d fake-hwclock defaults
insserv: warning: script 'K01tightvncserver' missing LSB tags and overrides
insserv: warning: script 'tightvncserver' missing LSB tags and overrides
Executing /usr/sbin/update-rc.d fake-hwclock enable

insserv: warning: script 'K01tightvncserver' missing LSB tags and overrides
insserv: warning: script 'tightvncserver' missing LSB tags and overrides
  • google rtc raspberry; it will help. You shoud however get the correct time from an ntp server... – Rui F Ribeiro Nov 23 '16 at 7:12
  • Can you set the current date and time with something like date -s "2016-11-24 0:14"? – Julie Pelletier Nov 24 '16 at 5:14
  • Most (if not all) NTP servers will refuse to sync when the time difference is too great, so you need to set it manually at first. – Julie Pelletier Nov 24 '16 at 5:22
  • @Julie: yes it works – user3486308 Nov 24 '16 at 9:23
  • After setting the time and time zone properly, try installing fake-hwclock as suggested by GAD3R and it should probably be fine. – Julie Pelletier Nov 24 '16 at 16:03
1

Set up your ntp server correctly and run the hwclock --systohc command.

Then install the fake-hwclock package , enable and start the fake-hwclock.service:

systemctl enable fake-hwclock.service
systemctl start fake-hwclock.service
systemctl restart fake-hwclock.service

Some machines don't have a working realtime clock (RTC) unit, or no driver for the hardware that does exist. fake-hwclock is a simple set of scripts to save the kernel's current clock periodically (including at shutdown) and restore it at boot so that the system clock keeps at least close to realtime. This will stop some of the problems that may be caused by a system believing it has travelled in time back to 1970, such as needing to perform filesystem checks at every boot.

On top of this, use of NTP is still recommended to deal with the fake clock "drifting" while the hardware is halted or rebooting.

Edit

This problem is solved by runnig dpkg-reconfigure tzdata(from @user3486308 comment's)

  • I did it but didn't work! – user3486308 Nov 23 '16 at 10:13
  • @user3486308 add the 4 servers from here – GAD3R Nov 23 '16 at 10:19
  • @user3486308 what is rhe ouput of cat /etc/fake-hwclock.data? – GAD3R Nov 23 '16 at 10:22
  • 1970-01-01 02:17:01 – user3486308 Nov 23 '16 at 10:25
  • 1
    I did configure the time zone with this command "dpkg-reconfigure tzdata" and problem solved! – user3486308 Nov 29 '16 at 7:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.