1

recently in the lab we bought some HDs and a new flash drive for research stuff. My surprise was when I tried to connect them to linux. Gnome mounted them normaly, but did not exist the /dev/sdb1 partition, the system only seen /dev/sdb. In that momment was an "emergency service", then I created a new partition table on the HDs/stick and everything worked fine, but now I want understand what happened there. Mainly because some scripts broke since they were looking for /dev/sdb1 specifically.

I tried to search about, but I don't know how to start. Some advice?

  • Too much info is missing - was the drive gpt partitioned, while your partition tool only knows "msdos" style partitions? Or maybe the drive was never partitioned in the first place? When you say "mounted" - what do you mean? Usually mount only refers to a filesystem – Dani_l Nov 22 '16 at 14:22
  • Thank you for answer. 1) The system can use gpt, I was trying to reproduce the conditions formating other drive as gpt but the partitions are showed normally. 2) When I said mounted, it was realy mounted. Nautilus popped up the empty directory (I have write privilegies). I think that the drive was never partitioned. I thought that mount non-partitioned system was impossible. – vialrogo Nov 24 '16 at 18:53
1

Nothing magic. You can create filesystem on a bunch of sequential blocks. It can be a block device, a partition, a file or a ramdisk... An iso file also doesn't contain any partition, but we can mount easily as loopback device. For example you can create more partitions on floppy disks (/dev/fd0) but it is very pointless on 1.44mb.

  • I think that that is the key! Thank you! It was very close to mount a CD/DVD, you mount the device, but you don't have partitions. Now I am trying to figure out how to create that kind of drives. – vialrogo Nov 24 '16 at 18:58
  • Ok, now I know how to create that system. I useed gparted to create a loop partition table. Then formated the device as fat32. I think that this configuration was the factory settings. Thank you for help me to understand. – vialrogo Nov 24 '16 at 19:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.