1

I am trying to downgrade my version of RPM as a package itself rather then just downgrading an .rpm of some other package.

I am trying to create some .rpm files but the target machines have such an old version of RPM installed that it looks like my current .rpm supplied uses newer libraries.

[root@lonlx1071b11 tmp]# rpm -ivh agents-1.0-1.x86_64.rpm
error: Failed dependencies:
    rpmlib(FileDigests) <= 4.6.0-1 is needed by agents-1.0-1.x86_64
    rpmlib(PayloadIsXz) <= 5.2-1 is needed by agents-1.0-1.x86_64

My current RPM version is:

root@localhost tmp]# rpm --version
RPM version 4.11.3

Target current RPM version is:

[root@lonlx1071b11 ~]# rpm --version
RPM version 4.4.2.3

When I try to yum downgrade rpm-4.4.2.3-36.el5_11.x86_64.rpm

I get dependency errors. Removing RPM and re-installing it doesn't work either as it says I try and remove yum and that's protected. So I assume yum is using RPM

If there is an obvious solution to this I apologise but I have not a fair bit of research and I can't really seem to find a solution.

I can post the dependency errors if required but they are fairly large. I have left them out for now to make the question easier to read.

  • I am extremely new to Linux so I might need some clarification on answers. Sorry! – Pudding Nov 22 '16 at 10:56
  • FYI, yum uses rpm under the hood. Why do you want to downgrade RPM, anyway? That's not something a newbie to Linux should generally need or want to do. – Wildcard Nov 22 '16 at 10:58
  • Yeah I thought so. Because I need to build the .rpm files for an older machine and the error given when trying to install those .rpm file suggests that its the older version of RPM that is causing a problem. – Pudding Nov 22 '16 at 11:00
  • I would bet it's the tool you're using to build the RPM. rpmbuild, perhaps? And I would bet that has options to build rpm files for older versions of the rpm installer. Have you looked into that? – Wildcard Nov 22 '16 at 11:05
  • 1
    If you find the answer yourself, you can self-answer your question; that's generally better than taking it down. – Wildcard Nov 22 '16 at 11:21
0

According to http://rpm.org/max-rpm-snapshot/ch-rpm-b-command.html

I can use --rcfile to use a different set of RPM defaults.

Unfortunately my access to the target is limited so I could not get the rcfile for this. I ended up just spinning up an early image of CentOS that uses the target rpm version and created the packages again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.