2

I've recently built a custom Embedded Linux version for my single-board computer using Yocto. But this build is new to me - there are neither /etc/init.d folder, nor /etc/networking/interfaces implemented. You can see what I have in /etc folder here:

busybox.links.nosuid  ld.so.conf            services
busybox.links.suid    libnl                 shadow
ca-certificates       localtime             shadow-
ca-certificates.conf  login.defs            shells
dbus-1                machine-id            skel
default               modprobe.d            slsh.rc
depmod.d              modules-load.d        ssh
environment           motd                  ssl
filesystems           mtab                  sysctl.d
fstab                 network               terminfo
group                 nsswitch.conf         timestamp
group-                os-release            tmpfiles.d
gshadow               pam.d                 udev
gshadow-              passwd                udhcpc.d
host.conf             passwd-               version
hostapd.conf          profile               wpa_supplicant.conf
hostname              profile.d             xdg
hosts                 protocols             yogurt-build-info
inputrc               resolv.conf           yogurt-version
iproute2              rpc
issue                 rsyncd.conf
issue.net             securetty

I've managed to connect it to network using ifconfig and route add commands but I cannot save those settings or at least make them executed on autorun.

Could you please advice me where to search for services and networking. Or what should I add to this build to have init.d, networking and ifup/ifdown?

  • 3
    You are using systemd as your init system. You need to configure the systemd-networkd service to connect to the net. ArchWiki has a pretty exhaustive manual on how to do that. wiki.archlinux.org/index.php/systemd-networkd – Munir Nov 22 '16 at 14:36
  • @Munir, You should have made it an answer. It helped me a lot. Thank you – PaulPonomarev Nov 23 '16 at 14:15
  • 2
    Please don't post images of text. I have transcribed the contents for you, but you may want to check for errors in transcription. – Fox May 7 '17 at 1:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.