2

I have here a CentOS 5 and I'm trying to run yum install php-soap but the installer hangs on and the last step is Running Transaction Test.

I found out that NFS shares are the problem. See here or here or here. I tried to unmount everything which came up when entering cat /etc/mtab | grep nfs. I also tried to use umount -a -t nfs. Then I run the install command. But I can't get this working.

strace yum -y update show me many lines, but I can't get a sense out of it.

Furthermore I tried

/bin/rm /var/lib/rpm/__db.*
cd /var/cache/yum
/bin/rm -rf *
yum clean all
yum update

but still hangs on.

Do I have to remove the mounts from the other server to this machine?

  • NFS mounts themselves are not necessarily the problem. Stale NFS mounts can be a problem, as mentioned in the links you provided. If df doesn't hang, and doesn't mention stale NFS mounts, then that is not likely the cause of your problem. Can you provide the last 10-20 or so lines of the strace output? – Lars Rohrbach Mar 23 '12 at 4:29
0

Just do this steps : 1. Kill all RPM and yum processes (rhn_check, yum, rpm, rhn-applet):

ps -axwww | grep rpm

n the list of processes, the first number on each line is the PID. For all PIDs listed except for the one associated with grep:

kill -9

Repeat the above steps for each of the programs listed.

  1. Remove any RPM lock files (/var/lib/rpm/__db*):

rm -rf /var/lib/rpm/__db*

  1. Rebuild the RPM database:

rpm --rebuilddb

Have Nice time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.