16

An application wants to access the keyring 'Default Keyring'

Chrome/Chromium prompts me for a password each time it opens. I don't know why it isn't integrated directly with the OS to unlock with login, but there isn't any obvious way around it.

I read that I need to

rm ~/.gnome2/keyrings/default.keyring

but I have no such file in my GNOME-less Xfce installation.

9

This problem has a long history and you can fiddle around with gnome-keyring if you want, but I found that the easier solution is to set that prompt's password to blank, such that it won't ask you anymore:

  1. rm ~/.local/share/keyrings/* (you may want to check/backup these files first, if you're not on a fresh install, e.g., cp -r ~/.local/share/keyrings ~/keyrings-backup)
  2. Restart Chrome
  3. When prompted to create a keyring, continue without entering a password. (Turns out you would have been okay if you did this the first time.)
5
  • Pressing "continue" without entering a password crashed my system the first three times I did it. On the fourth time, I no longer receive prompts, all Gnome extensions were set to "disabled," and Chrome opens four tabs of the Gmail about page every couple of minutes.
    – Jamie
    Feb 13 '17 at 21:43
  • Didn't work for me, but running with --password-store=basic as per jbrock's answer did. May 19 '17 at 20:38
  • 1
    Great answer, thanks. Solved this long-term problem for me.
    – C26
    Nov 27 '18 at 12:48
  • 2
    Keyring without a password is not encrypted. How good is it then?
    – Grogi
    Mar 2 '19 at 9:51
  • Worked great with Opera and Xubuntu 19.04. Thank you! And, I'm not worried about any passwords saved to my browser being unencrypted because I use a third-party password manager and don't save passwords to my browser. Also, I run full dis encryption.
    – Nick
    Mar 22 '20 at 16:38
9

Don't know is this question is still relevant but I found a solution that works for me. I am running Debian Jessie i386. Use the XFCE desktop and gdm3 display manager. What I found was that going into the Applications Menu Settings>Session and Startup>Advanced and selecting Launch Gnome Services on Startup cured the problem. Not sure how this would be effected on other distros but it works on Debian Jessie.

4
  • 1
    I found the same solution on Xubuntu 17.04 (Zesty).
    – ʇsәɹoɈ
    Dec 12 '17 at 6:54
  • Thanks for providing a solution. Unfortunately, this is still relevant. Unfortunately your advice does not work for me debian stretch, with clean install XFCE destkop. Nov 18 '18 at 15:40
  • Helped me with Mint XFCE.
    – Grogi
    Mar 2 '19 at 9:52
  • Doesn't work on Xubuntu 20.04 with XFCE Oct 24 '20 at 7:44
2

I do not know what distro you are on, but I would create a script in ~/bin and call it chromium (for Debian) or chromium-browser (for Ubuntu). Be sure to adapt the script according to what Chromium is called on your distro:

#!/bin/bash
/usr/bin/chromium-browser --password-store=basic "$@" 

For Google Chrome, you can create another script in ~/bin and call it google-chrome-stable with the following:

#!/bin/bash
/usr/bin/google-chrome-stable --password-store=basic "$@" 

The above scripts will use the argument --password-store=basic for every instance when you launch one of the two programs.

From this source:

--password-store Specifies which encryption storage backend to use. Possible values are kwallet, kwallet5, gnome, gnome-keyring, gnome-libsecret, basic. Any other value will lead to Chrome detecting the best backend automatically. TODO(crbug.com/571003): Once PasswordStore no longer uses the Keyring or KWallet for storing passwords, rename this flag to stop referencing passwords. Do not rename it sooner, though; developers and testers might rely on it keeping large amounts of testing passwords out of their Keyrings or KWallets.

0

I wanted to comment, but it tells me I cannot because of too few reputation. So sorry for this 'answer'.

The answer from @Wolf to delete the keyrings in ~/.local/share/keyrings/ helped me too. From there on I saw in Default_keyring.keyring an explanation for this behaviour.

It seems there is a quirk in the GNOME libsecret API and google just adds a dummy entry with libsecret when initializing OSCrypt. See: https://bugs.chromium.org/p/chromium/issues/detail?id=660005 for more details.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.