0

I have a retina MBP with OS X El Capitan (10.11.6) on a 15" Mid 2014 laptop. I basically, long ago, followed http://davidlively.com/notes/macbook-pro-triple-boot/ and it has been working for a long time.

I think I screwed it up though when I installed fuse-ext2 - I'm not blaming that project, maybe I did something, but at any rate, now when it starts I only get a dimly lit black screen. I have to hold down Option key and the I only get 3 icons: OS X, OS X, and WINDOWS. The middle one "doesn't work" it just sits there. Windows used to work but not it complains of not being able to start. From Mac (the first one), El Capitan works fine and I can see the contents of the Windows partition (it was made with Bootcamp).

Here is some info about my layout of the SSD:

sbhs-MBP:Volumes sbh$ diskutil list
/dev/disk0 (internal, physical):
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *1.0 TB disk0
1: EFI EFI 209.7 MB disk0s1
2: Microsoft Basic Data BOOTCAMP 200.8 GB disk0s2
3: Apple_HFS DATA 272.9 GB disk0s3
4: Apple_HFS OS X 249.5 GB disk0s4
5: Apple_Boot Recovery HD 650.0 MB disk0s5
6: Linux Swap 20.0 GB disk0s6
7: Microsoft Basic Data 215.3 GB disk0s7
8: Linux Filesystem 40.7 GB disk0s8

Btw, #3 is just a shared partition with data on it - no OS; 7 & 8 are linux mint 17.3 and 18; also csrutil is disabled; and if it matters, nothing is journaled.

If I use a live mint stick I can see everything on disk0s7 and disk0s8, and think they are probably okay. It seems to be a booting issue.

Most recently I have re-blessed rEFInd on the EFI partition (/dev/disk0s1) and yet I still get a dimly lit black screen... Currently though I am writing this on the El Capitan (disk0s4)

Also, everytime I install (and bless) refind, it gets the dimly lit black screen, so I restart it with the Option key held down, and boot into the first OS X. I then notice that under the preference pane for the startup disk, it has changed to BOOTCAMP/Windows...?

I am at a loss as to how to get all these boot issues fixed. Thank you all much for your help and advice,

Brett

update 1

According to this, https://apple.stackexchange.com/questions/57597/how-to-fix-broken-efi-partition , I apparently do not have the same problem as the OP did...

sbhs-MacBook-Pro:refind-bin-0.10.4 sbh$ sudo gpt -r show disk0
gpt show: disk0: Suspicious MBR at sector 0
       start        size  index  contents
           0           1         MBR
           1           1         Pri GPT header
           2          32         Pri GPT table
          34           6         
          40      409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
      409640   392254992      2  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7
   392664632      262144         
   392926776   533068472      3  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
   925995248      262144         
   926257392   487273856      4  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
  1413531248     1269536      5  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC
  1414800784    39064176      6  GPT part - 0657FD6D-A4AB-43C4-84E5-0933C84B4F4F
  1453864960   420589844      7  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7
  1874454804      261732         
  1874716536    79493256      8  GPT part - 0FC63DAF-8483-4772-8E79-3D69D8477DE4
  1954209792         295         
  1954210087          32         Sec GPT table
  1954210119           1         Sec GPT header

and in fact gdisk says it is okay...

sbhs-MacBook-Pro:refind-bin-0.10.4 sbh$ sudo gdisk /dev/disk0
GPT fdisk (gdisk) version 1.0.1

Warning: Devices opened with shared lock will not have their
partition table automatically reloaded!
Partition table scan:
  MBR: hybrid
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with hybrid MBR; using GPT.

Command (? for help): v

No problems found. 786321 free sectors (383.9 MiB) available in 5
segments, the largest of which is 262144 (128.0 MiB) in size.

update 2

I reset NVRAM and SMC. Now the preference pane for startup in El Capitan does not have a selected startup disk. I re-disabled csrutil; still not journaled; no FileVault either

0

Well all, I know there might not have been a lot of information on this case but I'm going to say what I did and its (successful) outcome anyway - maybe it will give someone an idea as to how to fix their similar problem.

So with basically just a working OS X on /dev/sda4 (recovery on /dev/sda5), I reinstalled Win 10 from the BootCamp-made USB drive (the standard way of doing it I guess). I let it finish and install all the drivers and reboot. Then my laptop only would start up in Win10. Using the Option key I could pick OS X though. I then, using a LM18 USB, followed https://community.linuxmint.com/tutorial/view/2283 and did "Section 2" on reinstalling grub. I, as I did when I first followed "David Lively" in the link above, made sure to install it on /dev/sda9. (It would have been sda8 but when I reinstalled Win10 I got a new partition afterwards. I don't know what it is, nor care ha ha, but everything works so I'm not going to fix it by breaking it :D

After grub was reinstalled, I could then restart using Option key and still only saw OS X, OS X, and WINDOWS. I didn't try the 2nd OS X as it always failed (still don't know about it), but booting into OS X I then re-blessed rEFInd and rebooted. Then I saw a ton of options on my rEFInd list. Four of them work: Windows 10, OS X, LM17.3 and LM18. I did not try any of the others (things like "Legacy...." and Recoveries). I may try the OS X recovery but I don't feel like pushing right now.

So basically reinstalling GRUB on top of / seemed to do it, and then re-blessing rEFInd from OS X.

Good luck to all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.