0

I have a dual boot system for a while now:

Windows 10 and Arch Linux and Grub2 to select between them.

I cleaned my PC and after putting it together, it didn't recognize my HDD, so I changed some settings in BIOS. Turned out, I forgot to plug in the HDD back in. So, I plugged it in, but now I can only boot into Windows. When I go into BIOS, I have 2 options for my HDD to choose from: - Windows Boot Manager (P6: my hd) - P5: my HD

First one brings me into Windows, second one tells me to "Reboot and Select proper Boot device" Booth UEFI and Legacy are activated. I think, the problem is, that P5 (Partition 5?) is just not the right partition, but I can't select any other. Here is what my partitions look like:

It looks in Windows Disk Manager like this Any suggestions?

  • I rarely have issues like this, but when I do I boot into an ubuntu live environment via usb and install and run the boot-repair utility. So far it's always worked for me when I had similar issues. help.ubuntu.com/community/Boot-Repair – hermancain Nov 20 '16 at 18:59
  • P5 and P6 probably stand for SATA ports 5 & 6 which your drives are plugged into. – Johan Myréen Nov 20 '16 at 20:03
  • boot-repair gave me some strange error something about a repository I have to add. Maybe I try an Arch Linux Live CD tomorrow – a.j. tawleed Nov 20 '16 at 20:25
  • the funny thing is: there is nothing on Port 5, but you seem to be right, since my second HD is listed as P2 and is on Port 2 – a.j. tawleed Nov 20 '16 at 20:26
  • 1
    You shouldn't use grub with an UEFI computer, you should use systemd-boot instead. – cylgalad Nov 21 '16 at 9:41
0

So after tinkering around for a while I finally found a solution. I used boot-repair, thanks to hermancain for the suggestions

But not for what, it is indented for (since that didn't work), but to get into my linux filesystem and get my grub-config (/boot/grub/grub.cfg) and searched for the entry for my Linux-boot. I made a picture with my smartphone and then I booted to boot-repair again, which has GRUB and instead of booting boot repair, I pressed C for the console. Now I repeated the steps from my grub.cfg:

set root=(hd3,gpt5) ## it was hd1,gpt5 in my config-file, but with ls, I found the right partition in this environment
linux /boot/vmlinuz-linux root=/dev/sdb5 rw quiet ##my config-File used the UUID, but I didn't want to type that in
initrd /boot/intel-ucode.img /boot/initramfs-linux.img
boot

After finally booting into my Linux, I opened a console and executed

grub-install

Now, I could finally select the right boot-entry in my BIOS again(The P5 entry disappeared and I have still no idea, what that was supposed to be).

I think, I should go with the times and will install systemd-boot like suggested by cylgalad in the next few days, so something like that won't happen again.


Followup:

I have some other problems with my PC, so I did reset BIOS. Than I had the same problem. I even already had systemd-boot installed. So, this didn't change anything. The problem is obviously that when BIOS scans the HDDs for the first time, it only recognizes the Windows Boot Manager, but not the Linux Boot Manager in the EFI partition. I guess reinstalling GRUB, systemd-boot notifies BIOS about that and that is when you can select it in the boot menu. The P5 entry was also there, the second time and disappeared after reinstalling systemd-boot.

The motherboard with this problem is an ASUS M5A99X EVO R2.0 with the latest BIOS version (2501) installed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.