2

I'm installing Fedora Server 24 onto an old Lenovo M91p (intel i5). It came with an installation of Windows 10, which I've wiped, and I'm using the gui installer from Fedora Server.

In the BIOS, I have changed BOOT MODE from [LEGACY] to [UEFI].

After booting up on the USB drive containing the Fedora Server 24 iso, I walk through the installation procedure flawlessly. In particular,

  • The installation source is detected. It finds the Fedora-S-dvd-x86_64-24 on /dev/sdb. Verifying the installation media returns a valid response.

  • The installation destination is automatically found. A western digital hard drive: ATA WDC WD2003FYYS-0.

During the installation, I opted to reclaim space but allow the installer to automatically configure the partitioning. During the reclamation, I deleted all the previous partitions. The desk partition scheme looks like this:

gdisk -l /dev/sda
GPT fdisk (gdisk) version 1.0.1

Partition table scan:
MBR: protective
BSD: not present
APM: not present
GPT: present

Found valid GPT with protective MBR; using GPT
Disk /dev/sda: 3907029168 sectors, 1.8 TiB
Logical sector size: 512 bytes
Disk identified (GUID): [...]
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 3907029134
Partitions will be aligned on 2048-sector boundries
Total free space is 2157 sectors (1.1 MiB)

Number    Start (sector)    End (sector)      Size      Code    Name
  1               2048           411647     200.0 MiB   EF00    EFI System Partition
  2              411648          1435647    500.0 MiB   8300
  3             1435648       3907028991     1.8 TiB    8300

After the installation completes, I reboot, and I'm greeted with the following screen:

Error 1962: No operating system found. Press any key to repeat boot sequence.

After browsing around, I've tried the following:

  • Changed BOOT MODE (as above) both ways.
  • Changed ATA boot from LEGACY to EFI and back again.
  • Changed the boot sequence order

According to this, the M92p ThinkCentre has a whitelist of efi labels. It apparently only boots from a label called "Red Hat Enterprise Linux."

I don't know how to specify the bootloader-id during Fedora installations. Before trying an arch installation, I was wondering if anyone else has any suggestions on what to diagnose, where to go, or what's wrong.

When I first received the machine, it successfully booted Windows 10, which makes me thing this is not an issue with the SATA cable or the drive itself.

  • You've probably already checked the obvious, but I had this issue a couple weeks ago and it turned out I had an external hard drive plugged in via usb and my computer was set to boot from usb first every time instead of the internal hdd. Unplugging the external drive forced it to boot properly. – hermancain Nov 20 '16 at 19:05
2

Lenovo's M91p and M92p have hardcoded rejection rules for any bootloader-id other than "Windows Boot Manager" (or on M92p "Redhat Enterprise Linux"). We can overwrite the bootloader with something like efibootmgr.

  1. Load a live installation onto the machine
  2. mount the boot partition and check the qualified path name (i.e. /boot/EFI/fedora/grubx64.efi (or whatever)
  3. Use a tool like efibootmgr to create a new entry that points to the relevant bootloader but names it appropriately. Note, you need to create a new entry since you cannot modify an existing bootloader-id.

The command will look something like:

efibootmgr -c -d /dev/sdX -p Y -L "Windows Boot Manager" -l "\EFI\path\file.efi"

You can then check the bootloader order and erase the old bootloader from you system.

0

The problem is with UEFI. So make sure, the installation doesn't create the /boot/efi partition.

For example, you can do this:

Choose "partition by hand" instead of automatic partition. Then leave the LVM method, and add partitions for

/boot / /home

and create a swap partition.

  • I remark that I had the same error just yesterday (that's how I got to this web page), and my recommendation worked. – Máté Wierdl Dec 9 '16 at 16:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.