2

I have a dual booted system, and its been years since I have used the linux side. I am running Fedora15 and am trying to upgrade. I have tried

yum install preupgrade

and I get the error message

Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again

I have tried

yum clean all
rm -f /var/lib/rpm/__db*
rpm --rebuilddb

yum update yum
yum update

yum erase apf

sudo sed -i 's/https/http/g' /etc/yum.repos.d/epel.repo

and I am still at a loss. I get a similar error messages.

Error: Cannot retrieve repository metadata (repomd.xml) for repository: updates-testing-debuginfo. Please verify its path and try again

I am hoping to upgrade my system, or to at least update the packages. Does any one have any other suggestions? Let me know if you need additional information.

1

EOL of Fedora 15 was 4 years before - on 2012-06-26 - so you are trying to update non-supported system. There are no updates nor security fixes. I'm afraid, that you are not able to upgrade your system to newest stable Fedora (24) easily and the best solution is to backup all and download and install stable system from scratch.


If you are trying just to update your packages to latest version from Fedora 15, than you can edit files under /etc/yum.repos.d/ and use archived repository from https://archives.fedoraproject.org/pub/archive/fedora/linux/releases/15/Fedora/. You have to edit baseurl and set correct url based on the link:

# /etc/yum.repos.d/fedora.repo
[fedora]
(...)
baseurl=https://archives.fedoraproject.org/pub/archive/fedora/linux/releases/$releasever/Everything/$basearch/os/
(...)

# /etc/yum.repos.d/fedora-updates.repo
[updates]
(...)
baseurl=archives.fedoraproject.org/pub/archive/fedora/linux/updates/$releasever/$basearch/
(...)

But, don't do it. Just reinstall.

  • Thanks for your input and quick response! I will take your advice and just backup and reinstall. – Techie91 Nov 20 '16 at 1:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.