0

I created an rpm with the following name -

product-name-subname-1.0.0.3.65-1 

but having issues listing it using yum from a remote server. Repository is properly configured because I created the same rpm file but with different version

product-name-subname-1.0.65-1 

No issues doing from the repository server itself- it says both files are available when I run the following command

yum -d 0 -e 0 -y list  product-name-subname-1.0.0.3.65

yum -d 0 -e 0 -y list  product-name-subname-1.0.65

Is there some convention/limitation on the version name - 1.0.0.3.65?

Is it too long and cannot be recognized when doing a remote yum list?

Here's a visual - I ran it in the repo server

In the Repo Server

In the remote server

In the remote server

  • 1
    having issues listing it using yum from a remote server is very vague. Afaik there are no real limitations; although most people would use 3 numbers (semantic versioning: semver.org) – Chris Maes Nov 18 '16 at 17:49
  • thanks for the info. yes, its vague. I added an image to show it. Is this something in some configs? – atong Nov 21 '16 at 22:09
0

No, it is not too long. The only practical limitation on versions in RPM is that you should avoid a few special characters like “-” and “:”.

Could it be that the metadata on the remote machine is old? If you do yum clean all or at least yum clean metadata, does it make any difference after that.

B.t.w., why do you disable error messages?

Continued investigation

I continue answering here. It unfortunately breaks the comment flow, but the character limit in the comment area is too low.

The meaning of --showduplicates is simply to list all versions of the package, not only the latest. It was just a way to confirm.

I get the impression that you see different repositories, or at least different repository metadata, on the two hosts. A few more tries:

  1. When you list the packages on the server side, are all the packages listed as coming from the same repository? (You have masked that part in your dump.)
  2. If you do yum repolist -v your-repository on that repository, both on the server and the client, how do the sides compare? In particular, are the number of packages and the latest update of the repository the same?
  • i ran the clean commands, but still no luck. Regarding the error disabled - I did not see any alarming error when I have it enabled, plus I just copied a command being executed by our configuration management tool. I updated my posts. Are there any other info I can provide to shed some light. Thanks. – atong Nov 21 '16 at 22:12
  • You are sure you are using the same repository, right? It's not that you have copied it, and then just updated one of the copies, or something like that? What happens if you do a yum list --showduplicates product\* on each side? – Göran Uddeborg Nov 22 '16 at 8:34
  • By the way, you forgot to mask the product name in one place in the second listing. Not that I think you reveal very much that could be secret, but still. – Göran Uddeborg Nov 22 '16 at 8:39
  • Thanks for letting me know and taking time on this matter, I am really new to this repository stuff. I am really not sure if I could divulge that publicly so I just took one more step to hide it. --showduplicates displayed it on the Available Packages section but there were no the same versions. What is it implying as duplicate? – atong Nov 22 '16 at 13:48
  • I listed packages from the repository on the server side and all the packages are coming in from the same repository. I also ran the command you provided on the repository name that showed up on the server side, and it gave the same repo-id and status is enabled. Do you need visuals? Thanks. – atong Nov 28 '16 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.