0

I am trying to start Circos in Debian but I get two missing modules

root@masi:/home/masi/circos-0.69# bin/circos -modules | grep missing
missing            GD
missing            GD::Polyline

Trying to install

root@masi:/home/masi/circos-0.69# cpan GD
CPAN: Storable loaded ok (v2.49_01)
Reading '/root/.local/share/.cpan/Metadata'
  Database was generated on Fri, 18 Nov 2016 15:53:48 GMT
Running install for module 'GD'
CPAN: Digest::SHA loaded ok (v5.88)
CPAN: Compress::Zlib loaded ok (v2.064)
Checksum for /root/.local/share/.cpan/sources/authors/id/L/LD/LDS/GD-2.56.tar.gz ok
CPAN: File::Temp loaded ok (v0.2304)
CPAN: YAML loaded ok (v1.13)
CPAN: Parse::CPAN::Meta loaded ok (v1.4414)
CPAN: CPAN::Meta loaded ok (v2.142690)
CPAN: Module::CoreList loaded ok (v5.20150214)
CPAN: Module::Build loaded ok (v0.421)
Configuring L/LD/LDS/GD-2.56.tar.gz with Build.PL
**UNRECOVERABLE ERROR**
Could not find gdlib-config in the search path. Please install libgd 2.0.28 or higher.
Warning: No success on command[/usr/bin/perl Build.PL --installdirs site]
  LDS/GD-2.56.tar.gz
  /usr/bin/perl Build.PL --installdirs site -- NOT OK

I also did apt-get install libgd and cpan libgd but does not help.

OS: Debian 8.5
Perl: 5.20
Linux kernel: 4.6 backports

2
sudo apt-get install libgd-perl

will install GD and GD::Polyline.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.