1

By not working I mean:

Speakers make noise when the plug is moved from one receptacle in the back of the card to another. No sound or even noise is produced when running either speaker-test or aplay.

I bought a cheap sound card (StarTech PCISOUND5CH2) find again the sound is extremely hard to get to work. I'm working with Alsa because I assumed that the upper levels would never work unless I could get Alsa to cooperate. This one was at least reported to have worked on Linux at some point.

I disabled the motherboard's onboard sound because it's some Realtec variant and didn't work either. I ran alsamixer to turn up all the volumes.

My Setup:

uname --all
Linux localhost.localdomain 4.8.6-201.fc24.x86_64 #1 SMP Thu Nov 3 14:38:57 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

OS: Fedora 24

My ALSA information is here.

Confusingly, there's many sound devices values reported by aplay -L, among them a sysdefault:CARD=CMI8738, but nothing labeled something intuitive, like say "default".

I tried the advice on the Alsa doc to disable the DAC exchanger and the IEC8738, but I'm not sure I did that right as I was only able to turn those down to 0.

In no case do I get sound, but some times I get a cryptic error message from aplay like:

aplay --device=rear:CARD=CMI8738 ./sine.wav  --channels=1
Playing WAVE './sine.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Mono
aplay: set_params:1303: Channels count non available

If you look at aplay.c at line 1303:

err = snd_pcm_hw_params_set_channels(handle, params, hwparams.channels);
if (err < 0) {
    error(_("Channels count non available"));
    prg_exit(EXIT_FAILURE);
}

it merely checks the error code returned from the snd_pcm_hw_params_set_channels function. The documentation I read suggest that it's actually providing more information, but the source code is ignoring it and reporting a broad error. Unfortunately, the tools are not building out of the box (or git repo), so I'm not able to make the one change I'd like to see the real error.

Why is it fighting me so badly to work? Would I be better off just getting a USB dongle and plugging it in? Can someone point to one purchasable as of the posting date Linux sound card that actually works in Fedora 24? I've been through 3 sound systems now.

  • 1
    You are running pulseaudio. Pulseaudio access all ALSA devices, which usually means exclusively (because most ALSA drivers are built that way) so the first step is to stop pulseaudio completely (verify with ps). Maybe that already fixes the problem. If it works, and you want to use Pulseaudio, you also need to configure the ALSA compatibility layer in your asound.conf. – dirkt Nov 18 '16 at 7:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.