0

I am unable to use qemu:

# qemu-system-x86_64 /dev/sdb
qemu-system-x86_64: error while loading shared libraries: libjpeg.so.8: cannot open shared object file: No such file or directory

Packages were already installed

# aptitude search libjpeg                 
     1  i  libjpeg-dev - Development files for the JPEG library [dummy package]
     2  v  libjpeg-progs - 
     3  i A libjpeg-turbo-progs - Programs for manipulating JPEG files
     4  p  libjpeg-turbo-progs-dbg - Programs for manipulating JPEG files (debugging symbols)
     5  v  libjpeg62 - 
     6  i  libjpeg62-turbo - libjpeg-turbo JPEG runtime library
     7  p  libjpeg62-turbo-dbg - Debugging symbols for the libjpeg-turbo JPEG library
     8  i A libjpeg62-turbo-dev - Development files for the libjpeg-turbo JPEG library

What additional package or which modification do I have to do to make qemu working?

1 Answer 1

2

The following procedure can be used to find out which packages provide a particular file:

sudo apt-get -y install apt-file
sudo apt-file update
sudo apt-file search libjpeg.so.8

On recent Ubuntu, the file you need is provided by the libjpeg-turbo8 package. However, there might be something wrong with your system if it let you install qemu without all required dependencies.

1
  • I think that on CentOS, it will be: yum provides libjpeg.so.8 Commented Sep 7, 2017 at 19:41

You must log in to answer this question.