0

I am on Kali Linux.

I'm trying to install the Broadcom BMD4360 drivers in my MacbookPro i7, in live USB mode, but I got some errors.

Is there any way to fix it without reinstall all over again?

So, first I installed the headers:

 apt-get update

 apt-get install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') broadcom-sta-dkms

After I removed the possible conflicts

modprobe -r b44 b43 b43legacy ssb brcmsmac

And got this:

root@kali:/etc/apt# modprobe wl
modprobe: FATAL: Module wl not found in directory /lib/modules/4.6.0-kali1-686-pae

So I tried to install in a different way and I had:

root@kali:/var/lib# apt-get install broadcom-sta-dkms
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  broadcom-sta-dkms
0 upgraded, 1 newly installed, 0 to remove and 1185 not upgraded.
Need to get 0 B/2,207 kB of archives.
After this operation, 14.5 MB of additional disk space will be used.
Selecting previously unselected package broadcom-sta-dkms.
(Reading database ... 335533 files and directories currently installed.)
Preparing to unpack .../broadcom-sta-dkms_6.30.223.271-4_all.deb ...
Unpacking broadcom-sta-dkms (6.30.223.271-4) ...
Setting up broadcom-sta-dkms (6.30.223.271-4) ...
Loading new broadcom-sta-6.30.223.271 DKMS files...
Building for 4.6.0-kali1-686-pae
Module build for kernel 4.6.0-kali1-686-pae was skipped since the
kernel headers for this kernel does not seem to be installed.

and after I got a new errors in modprobe:

root@kali:/var/lib# modprobe wl
modprobe: ERROR: ../libkmod/libkmod-module.c:832 kmod_module_insert_module() could not find module by name='wl'
modprobe: ERROR: could not insert 'wl': Unknown symbol in module, or unknown parameter (see dmesg)
modprobe: ERROR: ../libkmod/libkmod-module.c:977 command_do() Error running install command for wl
modprobe: ERROR: could not insert 'wl': Operation not permitted

My uname -a is

root@kali:/lib/modules# uname -a
Linux kali 4.6.0-kali1-686-pae #1 SMP Debian 4.6.4-1kali1 (2016-07-21) i686 GNU/Linux

The modules available are listed:

root@kali:/lib/modules# ls
4.6.0-kali1-686-pae  4.8.0-kali1-686  4.8.0-kali1-686-pae  4.8.0-kali1-rt-686-pae

and /var/lib/dkms/broadcom-sta/6.30.223.271/source/dkms.conf follows

root@kali:/var/lib/dkms/broadcom-sta/6.30.223.271/source# cat dkms.conf
PACKAGE_NAME="broadcom-sta"
PACKAGE_VERSION="6.30.223.271"
MAKE[0]="make KVER=$kernelver"
BUILT_MODULE_NAME[0]="wl"
DEST_MODULE_LOCATION[0]="/updates/dkms"
AUTOINSTALL="YES"
REMAKE_INITRD="YES

Is there any way to fix it without reinstall all over again?

1

I had this same issue; I followed every tutorial out there but couldn't get it to work :(

What did work was to download and install the packages manually.

First run

uname -r

to get your OS kernel version (for the purpose of this example 4.6.0-kali1-amd64).

Then download either in GUI the packages you need:

, or in CLI download them directly in terminal:

wget --continue http://http.kali.org/kali/pool/main/l/linux/linux-headers-4.6.0-kali1-common_4.6.4-1kali1_amd64.deb
wget --continue http://http.kali.org/kali/pool/main/l/linux/linux-kbuild-4.6_4.6.4-1kali1_amd64.deb
wget --continue http://http.kali.org/kali/pool/main/l/linux/linux-compiler-gcc-5-x86_4.6.4-1kali1_amd64.deb
wget --continue http://http.kali.org/kali/pool/main/l/linux/linux-headers-4.6.0-kali1-all-amd64_4.6.4-1kali1_amd64.deb

To install them, run:

sudo dpkg --install linux-headers-4.6.0-kali1-common_4.6.4-1kali1_amd64.deb
sudo dpkg --install linux-kbuild-4.6_4.6.4-1kali1_amd64.deb
sudo dpkg --install linux-compiler-gcc-5-x86_4.6.4-1kali1_amd64.deb
sudo dpkg --install linux-headers-4.6.0-kali1-all-amd64_4.6.4-1kali1_amd64.deb

Then download bcmwl-kernel-source_6.30.223.248+bdcom-0ubuntu8_amd64.deb either in GUI, or in CLI download it directly in terminal:

wget --continue http://launchpadlibrarian.net/226723001/bcmwl-kernel-source_6.30.223.248+bdcom-0ubuntu8_amd64.deb

To install it, run:

sudo dpkg --install bcmwl-kernel-source_6.30.223.248+bdcom-0ubuntu8_amd64.deb

And finish with there modprobe commands:

sudo modprobe -r b43 ssb wl brcmfmac brcmsmac bcma
sudo modprobe -v wl

And voila, it should be working!

  • Hi! Thanks for your help @pmalbu ! So, I followed your steps, but I had some errors when I ran sudo dpkg --install linux-compiler-gcc-5-x86_4.6.4-1kali1_amd64.deb and sudo dpkg --install linux-headers-4.6.0-kali1-all-amd64_4.6.4-1kali1_amd64.deb commands... Basically the errors are: dpkg: dependency problems prevent configuration of linux-compiler-gcc-5-x86: linux-compiler-gcc-5-x86 depends on gcc-5; Did I something wrong? :( – Germano Nov 23 '16 at 2:31
  • Hi @Murchilla. Hmm no I am sure you did it correctly, but it appears that there are other unmet dependencies. I am not an expert in this area unfortunately, however Google may be able to help you out! – pmalbu Nov 24 '16 at 20:29
1

I found dependencies missing and this are all the packages I had to install.

Now works fine.

bcmwl-kernel-source_6.30.223.248+bdcom-0ubuntu8_amd64.deb   
linux-headers-4.6.0-kali1-common_4.6.4-1kali1_amd64.deb
linux-compiler-gcc-5-x86_4.6.4-1kali1_amd64.deb             
linux-headers-4.6.0-kali1-common-rt_4.6.4-1kali1_amd64.deb
linux-headers-4.6.0-kali1-all-amd64_4.6.4-1kali1_amd64.deb  
linux-headers-4.6.0-kali1-rt-amd64_4.6.4-1kali1_amd64.deb
linux-headers-4.6.0-kali1-amd64_4.6.4-1kali1_amd64.deb      
linux-kbuild-4.6_4.6.4-1kali1_amd64.deb

PS: This one helped a lot: apt --fix-broken install

protected by roaima Nov 6 '17 at 16:28

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.